Audacity stops after a few minutes recording [SOLVED]

Hi, I have seen my issue within the audacity forums but none of the solutions solve my problem.

Audacity has become a real pain of late as it just stops after 1-7 minutes.

How do I troubleshoot this so I can focus on recording?

I have cubase and voice recorder on windows 10 and never have an issue with them.

I only have windows security for viruses and superantivirus.

I have windows 10. Everything is up to date.
Latest 2.3.3 audacity,
And am using an M-Track USB interface. (I have used this many times before with no issues)

But now am having constant issues.

All I am trying to do is record a voice. (approx 45 mins) but finding it very difficult to get done.

Any help appreciated, thanks.

I actually solved this.

It was my webcam. I had unplugged the cam usb and thought that would solve the issue, as I believe it did previously.

However, the pc needed a restart which then solved the problem.

How strange. Thanks for posting the solution.
I shall close this topic as “solved” as it may be useful information for others.