Audacity, Stereo Mix no longer working

Had no problem using Stereo Mix to record before, now no audio is being registered by the Stereo Mix (as evidenced by no green bars lighting up to the right of the Stereo Mix).

Audacity 2.02, Windows 7, Realtek HD driver (8/30/2011)

This is what I’ve done:

*Stereo Mix Enabled (Realtek HD device working properly)
*Stereo Mix Default (Non-default mic’s green bars still lighting up)
*Stereo Mix → Properties-> Listen tab → Listen to this device box checked, playback through default device.
*Stereo Mix → Properties-> Level tab ->Level of Stereo Mix set to 100
*Level of Speakers set to 100
*Mic & Line in Disabled

I also used Skype to double check if Stereo Mix was working as the mic source while music was playing - No response from stereo mix

Any ideas?

Thanks in advance

Topic moved to the Windows forum.

Are you able to roll back Windows to a restore point when Stereo Mix was working?

In any case, you shouldn’t use “Listen to this device” for the stereo mix input, it will just create feedback echoes, the same as enabling Software Playthrough in Audacity while recording stereo mix creates echoes.

But the mic won’t usually record when choosing stereo mix unless you choose “Listen to this device” for the mic, or have unmuted the mic on the Playback tab.

What are you trying to record?


Thanks all…

Unfortunately, no rollback is far enough (more than 1 month).

I’m going to do several things w/audacity, like create custom ringtones, trying to mash up a couple of songs for a video, etc.

I unchecked the listen box, but still no dice. It’s like the audio isn’t going to the device at all.

Again, what are you trying to record exactly with stereo mix? Computer playback? The mic combined with computer playback?

Are you playing what you want to record on the Realtek device? You can’t for example play audio on a USB headset then record it with stereo mix on the Realtek - the headset and Realtek are different devices.

Have you looked at ? You may want to see if a sound driver update has caused this and roll back the drivers in Device Manager. Or if you cannot roll them back, uninstall and reinstall the sound device drivers, using the latest drivers made by the motherboard or computer manufacturer (not drivers obtained from the Realtek site which will not be matched with your motherboard).


Thanks Gale,

Just want to record straight from videos & streaming video, no mic, no headset, no 2nd source. Previously I had recorded an audio session back in May of this year, and it worked fine with the same drivers, but I’ll try switching the drivers.

Note that Skype will tend to take control of the sound card settings, so while testing this you should shut down Skype completely (NOT running in the background) so as to avoid complications from Skype.

Yeah, I did try without Skype first. Skype was simply a 2ndary test to see if a separate program could utilize stereo mix.