Audacity softlocks sporadically

full window screenshot.png
audacity 3.0.2 (also 2.3.2, actually every version of audacity seems to do this)

Windows 10 Pro

ryzen 5 2600 16gb of ram (which is pointless to mention since audacity only can use 4gb anyways)

details: doing literally anything. i could be applying an effect or resampling. as soon as a dialog comes up, audacity acts like there’s an invisible window stealing focus. the cursor freezes to whatever cursor icon it last was regardless of where i move it.
ctrl+scroll also seems to cause it.
cursor locking up.png
no error message (no “not responding” either.)

closing it via the taskbar asks if i want to save, but i can’t click anything on that dialog.
what happens if i try to close.png
nothing is grayed out.

searched everywhere, and everyone’s issues are either dead, or unrelated (they usually have grayed out things (nothing is grayed out for me) or a “not responding” (mine isnt doing that) and none of them match up with my issue. that and theyre usually from ~2008. on linux hosts.)

i’ve tried running a fresh copy of audacity (in this case i ran fresh 2.3.2) and it still happened

i’ve tried restarting and it still happens

this has happened to me a whole month prior on the same hardware, and it seemed to have fixed itself. or something. i have no clue what i did to fix it back then.

File size: fresh project (just imported 3 minutes of red book audio in FLAC) on a nvme ssd (so its not me recording a 9 hour podcast or something onto a 5400rpm hard drive thats running out of space)

i did absolutely nothing special before it started happening, it just did on its own.

It happened yesterday and i was writing this forum post, when it magically started working again when i tried to prove its existence using OBS. Today it randomly started happening again and I caught both a. it working normally a minute prior and b. magically not working after restarting audacity.

(ignore the weeb music)
the bug in action
audacity working fine (i restarted audacity to refresh it since it starts to become slow after using it for a while and usually this fixes it and ive done it plenty before)
what happens if i try to close.png

(why cant i edit my post?)
installed audacity 3.0.3 and the bug persists

It can become impossible to follow a discussion if previous posts change. Please just add a new post (as you did) when necessary.

What’s the audio app in the background? Is it using ASIO or ASIO4All?

sorry im used to forums telling people not to double post

FL studio, using fl studio’s built in asio

We don’t like “double posting” either :smiley: but by that I mean posting the exact same thing multiple times. Adding new information in a new post is welcome - anything that keeps discussions easy to follow is encouraged.

That could be the problem, or part of the problem.
ASIO tries to maintain exclusive access to sound devices, so when you say “like there’s an invisible window stealing focus”, that “may” be due to ASIO trying to maintain exclusive access to the audio device.

If you reboot your computer and do NOT start any other apps, ONLY Audacity, does the problem still occur?


even then, i’ve never had this issue with fl studio open on my old install or the install before that (and it was set to fl studio asio the rest of the time)

What has changed?

nothing has changed

i am still experiencing it. i reinstalled audacity (3.1.3) (resetting preferences) and it was working perfectly fine until i restarted it to apply settings.

as seen in the video, it doesnt even have to be dialog related, i could just be importing a file.

so it appears i can ONLY get audacity to run bug-free by re-installing and resetting preferences. every single time that either a. i want to use it or b. it crashes nevermind, it doesnt even work after a reinstall anymore.

i do not see how ASIO would even cause this anyways, this isn’t related to playback at all.