Audacity shows no input devices or channels

Jusy installed Audacityy from the Audacity site with the exe installer . . .I’m on Windows 7.
Then I installed the LAME_v3.99.3 for Windows . . . . but my input devices are nothing . . . . just blank space . . I did a rescan and still nothing.
Also input channels are blank as well.

Thanks for any help with this.


Go to the Windows Sounds Control Panel and enable a recording input device.

Thanks for the fast reply !

Under “Sound” and then the “Recording” tab . . . I only have

Line In

. . . which are all enabled

No “Audio CD” shown to enable.


I was wanting to select the “Rec. Playback (IDT High Definition Audio Codec)”

Sorry I don’t understand.
Is “Rec. Playback (IDT High Definition Audio Codec)” an option that you can see in Audacity, or in the Windows Sounds Control Panel, or somewhere else?

What exactly are you wanting to do?

I was told i’d be able to record music from the internet with Audacity . . Like off of my Bands Youtube Video’s.


So this is not possible to record from the internet using Audacity ?

I’m still womdering why nothing shows up in the input devices drop down menu . . . . .


It is possible if the sound device has a “stereo mix” or “wave out” option (almost no sound devices have a real “audio CD” input that is connected to the CD drive).

Have you right-clicked in the “Recording” tab of “Sound” in Windows and chosen “Show Disabled Devices”? If so, but there is no input for recording computer playback, see this page for alternative methods: .

After making device changes in Windows, choose Transport > Rescan Audio Devices in Audacity.