Audacity setup problem...line not open?

I got audacity installed, but it won’t record anything except through Pulse rear mic:0.

It won’t record on Pulse: line:0 (with stuff playing) or any of the other selections available, just Pulse rear mic:0, as mentioned.

Are the lines closed in Ubuntu and have to be opened in Terminal, or is this something that needs to be changed in Audacity?

How do I fix this?


What’s the goal? What are you trying to do?
Which version are you using?


I want to be able to record streaming material. It’s v 2.0.5

Try the “PulseAudio” method described here:

Try the “PulseAudio” method described here: Audacity Manual … linux.html<

No luck.

Here’s screenshot of the way Audacity and Gnome ALSA mixer is setup, and with which I can’t get any streaming in for recording.
I’ve tried lots output / input combinations - none work for streaming audio.

See anything that is messed up and needs changing?

I may have solved the problem. The “PulseAudio Volume Control” that I got during a download didn’t look like what is pictured in the tutorial you linked - there was no access to the tabs shown.

Just now I uninstalled what I had, re-installed, and got a “PulseAudio Volume Control” that looked like what’s in the tutorial.
I changed to “analog stereo output” in the config tab, and started getting recordable input in Audacity.


The best way to be sure of getting a compatible version of PulseAudio Volume Control for your system is usually to enter the following in a terminal:

sudo apt-get install pavucontrol