Audacity set up with Windows 7

I have made the set up with turntable AT 120 USB and when i connect the usb cable to my computer (usb port) and I got an USB codec unit right but the sound unit show “line audio-codec” as standard unit (activ) - not “microphone usb codec” (not activ). The last item is greyd out and cannot be changed or set as standard unit. I have check the set up at my turntable and computer and everyting seems right to me.

Furhter more I got the recording signal fairly low -12db and I have the input signal set to 98%. The PU has output 3,5 mv - maybe that is to low?

Is it the turntable AT120 and the built in RIAA to blame for the incorrect info - “line usb codec”.

Thanks for any help and tips :wink:

I moved this to the correct Windows board.

Quit Audacity.

Disconnect the USB turntable.

Right-click over the speaker icon by the system clock, then choose “Recording Devices”.

Connect the turntable. The USB device that appears in “Recording Devices” is the turntable. Windows Vista and later call USB audio input devices “Microphones” (even if they are not). If that device is unavailable or disabled, right-click over it and choose “Enable”.

When the device is enabled, launch Audacity.

Choose the turntable as input device in Audacity’s Device Toolbar . Choose your computer sound device for the output device.

I suggest you read this page for further assistance: .


No, I follow your instruction, quit Audacity and disconnect the turntabe and so on - the set up and information was the same - “line USB code” and the “microphone USB codec” was mot valid and the choise enable to “microphone” was not given.

Please bear in mind that we can’t see your computer. So you need to be precise in your descriptions.

Where exactly are those choices that you now describe as “line USB codec” and the “microphone USB codec”?

You said previously:

“line audio-codec” as standard unit (activ) - not “microphone usb codec” (not activ).

which looks like the “line” is the built-in audio device and not USB.

A USB turntable does not usually have a choice of two USB codec inputs. Where exactly are those “active” and “not active” devices listed?

Can you now choose the actual USB turntable input in Audacity’s Device Toolbar and record from it?

If not, please (in Audacity) choose Help > Audio Device Info… . Right-click in the Audio Device Info and “Select All”. Right-click again and “Copy”. Paste into your reply.


Dear Gale,

I try to answer your questions - "where éxactly are those choices that you now describe as “line USB codec” and “microphone USB codec”. That´s difference is in the Audacity bar (with the microphone ikon) next to "Speakers - Realtec HD) - the correct info should be (according to audacity and turntable manual) “microphone USB codec” - thats after connecting the turntable with the USB cabel to the computers USB port - now I get the info “line in USB codec”. The Connection and set up is Okey and the USB codec unit is also correct.

The next question “where exactly are those Active and Not Active item listed”? - Then you right click over the system Clock and chose “recording devices” and choose the tab “recording” you see the following item "Microphone (Realtec HD audio) - Line in (Realtec HD audio) - Stereo Mix (Realtec HD audio) - Line (USB audio codec). The item whitch are Active is the last one “line USB codec” and it is also “standard unit” - the other are not connected and not active and you cannot make it active or set them as standard either. The correct setting should be the first one “microphone usb audio codec” and the last one “line USB codec” wich now is activated should not be there.

Anyhow, I can however record in audacity and also monitoring the Music played and export them to MP3 - but the input level is a littel to low -12db but I can adjust it to -3 using “normalize”

Maybe it´s just the set up and the turntable (AudioTechnica 120 with USB and RIAA amplifier) who gives the “wrong” information and to low output from the PU (AT95E 3,5 mv)?

Rolf :open_mouth:

Well, I finally find the “problem” myself. The information in The Preferences and the “Line in USB Codec” instead of “normal” “Microphone USB Codec” is the way the turntable media sometimes behaves, in this case The Audio Technica Lp120 USB.

And for the somewhat low input and recording signal (-12.0 db) was simply that the built in amplifier in AT and in combination with the low output in the AT95E PU unit made the output and recording level to low.

After changing the PU for an Shure M44-7 with very high output 9,5mv the input signal via USB and recording level was nearly perfect -6db to -4db and that without having to turn the recording level mixer to maximum, 100% - now just 65-70%.

So for me, a new PU and the problem solved - it has nothing to do with my computer, my OS Windows 7 and not to do with Audacity either.

Thanks, roffe00. I’ll lock this topic now as it is a very specific issue and you have solved it.