Audacity Seems to close without notification.


I am trying to use audacity to record my voice while using FRAPS to record the game I’m playing, Team Fortress 2. However, since Team Fortress 2 is a full screen game I cannot check if audacity is open or stop and save and continue. So while FRAPS stays open and records the game, Audacity will decide to randomly close without ever telling me why and without saving. The recovery file is always an unimportant 10 second clip. I am wondering why it does this? Does running TF2 affect it? Does FRAPS affect it? If I record for more than 2 hours will it stop?

I am using Windows 7 with
-4GB of ram
-AMD Athlon™ IIX2 255 Processor 3.10 GHz
-64 bit

It may be a 64 bit problem, but I think it’s more likely two different high-energy, real-time programs struggling for the sound and video channels at once. Google will tell you there’s no shortage of people having trouble with FRAPS and other services. It’s not just Audacity.


Audacity should recover better than that. What version of Audacity do you have? Look in Help > About Audacity.

You can get the latest Audacity 2.0.5 from .

You should be able to record both your voice and the game audio in Fraps (obviously the result will be mixed together and you won’t be able to edit the voice separately from the game later). Enable “Record Win 7 Sound” and “Record external input” (set to your microphone). See: .


Thats my problem with recording my voice in FRAPS. I would like to be able to edit my voice separately for I am able to remove background noise. I have downloaded the latest version of Audacity 3 times. So right now I’ll keep trying to record with Audacity and Fraps and simultaneously record my voice with my iPod as a backup.

Have you enabled the “Reset Preferences” checkbox half way through the installer? If not, try that. It’s possible the recovery is OK but Audacity doesn’t record for long in the first place.

Can’t you still ALT + TAB to Audacity to see what it’s doing, even if FRAPS is full screen? If it’s full screen always on top, can you change that?

If you are recording the microphone in Audacity and stereo mix in FRAPS, don’t forget to uncheck “Record external input” in FRAPS.


Well, I’ll try that, what was strange was while recording with FRAPS, If i Alt-Tabbed out of TF2 and go back it goes to a black screen with the only the audio of TF2. Maybe I just need to wait a little and it will go back.

Well, unchecking external output and clicking reset preferences seemed to work. However I only recorded for 45 minutes and not 2 hours (like i usually do) Maybe it fixed or 45 minutes doesn’t crash audacity

If you meant “unchecking external input” (that’s what I meant), there is no benefit in recording your mic into FRAPS and Audacity at the same time when the whole point was to separate the two inputs.


I think I had it checked because I wanted to try to record my voice in fraps without audacity but it didn’t work, and I just forgot to uncheck it. Thanks for the help!