Audacity seems to be recording too slowly

This is a continuation from a thread

A new thread has been started as the problem is slightly different from the previous one. Thanks to Gale for the suggestion.

I have just started using Windows 10 and have put a new install of Audacity 2.1.2 onto it. I am sampling a variety of sounds that come through the sound card computer but mainly it is small clips of music from CDs to add to presentations not for distribution. I have been doing this so that I don’t have to import the whole track and then edit it.

For some reason, the recording is being laid down too slowly - the second markers click by at almost exactly 2 second markers for every 3 real seconds. As a result, the playback sounds too fast and too high.

I have been though the and also tried a variety of sampling rates always making sure to align the sound card rates with audacity.

My sound card is built into my motherboard (Asus P77z-v) and is Realtek® ALC892 8-Channel High Definition Audio CODEC . I have had to upgrade to the latest Realtek driver as I couldn’t get soundcard recording to work with the windows 10 built in drivers. The only way that I can get audacity to record is to have MME Stereo Mix (Realtek High Def) ‘Microphone’ and Play back is though speakers marked as ‘Speakers (Realtek High Def)’.

I am not mixing tracks or recording while playing back existing tracks.

Thanks for your help


Thanks for starting a new topic.

Some CD extraction apps like CDex will let you rip part of a track. If you rip to WAV then the rip is lossless.

Where does that Realtek driver come from? Drivers downloaded from Realtek are generic and not properly matched to your hardware. Occasionally specific problems can be solved with a generic driver but other problems may be created - possibly the problem you are having.

Did you try Windows WASAPI loopback recording instead? That may work better and save you changing drivers.

Is it a branded Asus tablet or notepad, or a branded computer manufactured by someone else, or a custom computer that was built for you? If branded by a computer manufacturer, the best place to look for Windows 10 audio drivers for your computer model is on that computer manufacturer’s site.

If it is custom built, the easiest way to figure out the drivers you should be using is probably to click the Windows button, type “dxdiag” (without quotes), then open DXDiag. Find the audio device Vendor ID (the numbers or letters following “VEN_”) and the Device ID (the numbers or letters following “DEV_”). Then look up that Vendor ID on and look for the Device ID on the page you come to.


Thanks for taking the trouble to reply, Gale

I built my own machine; the sound card is built into the motherboard. I have used Audacity before on it (I don’t remember the Build number) without problem under Win7. When I changed t Win10, whilst I could hear sound with the built in sound drivers and the realtek drivers from the Asus Support site, audacity didn’t work which is why I used the ones from the Realtek website latest version.

DxDiag says for speakers Driver is:
Description: Speakers (Realtek High Definition Audio)
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_104384FB&REV_1003
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: RTKVHD64.sys
Driver Version: 6.00.0001.7525 (English)
Driver Attributes: Final Retail
WHQL Logo’d: Yes
Date and Size: 02/06/2015 00:00:00, 4477656 bytes
Other Files:
Driver Provider: Realtek Semiconductor Corp.
HW Accel Level: Basic
Cap Flags: 0xF1F
Min/Max Sample Rate: 100, 200000
Static/Strm HW Mix Bufs: 1, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX™ 2.0 Listen/Src: No, No
I3DL2™ Listen/Src: No, No
Sensaura™ ZoomFX™: No

I couldn’t get WASAPI to work - there was a lot of feedback but I didn’t persist with it when I got MME to work so it was probably something I’d set up incorrectly.

In reality, when I apply the Sliding Time Scale / Pitch Change Effect at -30% all round, it seems to get it back to where it should be but it seems a very precise ratio (it’s not -33% for example) and I wondered whether it was associated with the Win10 ‘upgrade’.



That’s a strange problem!

If you can’t fix it with drivers, I’d suggest you buy a new soundcard that comes with Windows 10 drivers. You should be able to get a soundcard for less than $10 USD. Don’t get a “USB soundcard” because they are like laptops with only mic-in and headphone-out. Except, I did buy a USB soundcard just to have around for troubleshooting purposes.

If you want to get something a little higher-end, look for a [u]USB Audio Interface[/u] with line-level inputs.

…Timing (pitch and speed) problems are not that unusual, but usually there’s a slight error that only a musician notices when they try to play (or record) in tune. And, it’s usually a hardware-clock problem where the recording & playback speed/pitch matches and the problem only shows-up if you record on one device (like a USB microphone) and play-back on a different device.


I have been doing this so that I don’t have to import the whole track and then edit it.

I agree with Gale that you should “rip” the audio (digitally extract) when the source is a CD. Even though you have to edit, it will be faster once you get the hang of it. And, it will be lossless (no speed problems or other problems). …It still would be nice to solve the problem you’re having.

There is very little information about the Asus P77z-v motherboard online even on the Asus site. My suspicion is that board is quite old and does not support Windows 10. Do Asus claim it supports Windows 10?

So the support link for that ALC 892 chipset audio driver is and there is no driver download supplied by Realtek - you are expected to download drivers from the computer or motherboard manufacturer.

There are no useful search results for ALC 892 and Windows 10 other than suggestions of different generic drivers.

Did you turn Transport > Software Playthrough off?

I tend to agree with Doug. Buy a USB sound card that supports Windows 10.


Thanks both

I tried WASAPI and the same thing happens. There was no feed back this time so I must have set the Playthough setting incorrectly.

I have to admit that I don’t understand why it used to work and now it doesn’t after an OS upgrade not a change in hardware.

For now I’ll carry on applying the Sliding Time Scale / Pitch Change Effect and hold the sound card up my sleeve.

Thanks again



I think the answer is quite simple. You chose to upgrade to an operating system that your motherboard does not fully support.

Have you tried the Change Speed effect instead of Sliding Time Scale / Pitch Shift? Change Speed will be quicker and I would have thought give a better sounding result, as only resampling is involved.