Audacity running really slow

Hi All,
I’m running Mac Big Sur 11.6 on an M1 chip. Audacity is updated to 3.0.5. I’m editing audio (For a podcast) that is about 50 minutes long, currently with 2 tracks (previously had 3 vocal tracks and a music track, but managed to cut out a few of the tracks to try to make everything smaller, hoping that would help audacity run better.)

Opening the audacity project takes over a minute, selecting and timeshifting audio is slow, adjusting the envelope is worse, but it stops completely if I try to paste audio into one of the tracks.

I’ve edited hour long podcasts with the same or larger file sizes before with no issue, and now this one has slowed things down completely. I tried opening audacity in low resolution, as per suggestions in other posts, but that didn’t have any effect.

Any ideas for how to get Audacity running smoothly again?

So if you care to zip up your project and upload it to a file sharing service such as dropbox or google drive, I’ll take a look at it. Post (or PM me) a link. (I’m thinking that perchance your project might still have some wayward envelope control points left over from 3.03 or earlier. I can at least confirm or disprove this supposition, and I might be able to fix it for you.)

Thanks - I found a work around, and am not having the problem any more. I waited for everything to load, then exported the two tracks as an mp3 file. Then I opened that in Audacity and put in my third vocal track and the music track. That worked to get rid of the problem (which would include any envelope control points). But I didn’t save the original copy, so I can’t send it to see if that is the issue! I thought it had to do with file size, but I’ve worked on larger files, so the envelope issue is probably more likely.

Thanks for the update - I am glad to hear all is OK again. Stay with 3.0.4/5 &up to keep the wayward envelope points at bay. And the next time you transfer tracks from one Audacity project to another, do it as a .WAV or other lossless format. Repeated conversions to and from .MP3 format can destroy your recording. :smiley: