Audacity resetting permissions on audio files

Been using Audacity for years - re-installed it yesterday, and now when I edit an audio file, I can’t FTP it to my website - I get an error “553 Can’t open that file: Permission denied”. I have tried different FTP clients with the same results. I’ve tried installing versions 2.1.2, 2.3.1, and 3.3. Editing files with other audio editors works fine, but once I open the files in Audacity they won’t upload, even if I edit the file in the other audio editors afterwards, It’s like Audacity permanently edits the permissions. I look in the files properties in windows explorer and can see nothing wrong.

What could this be?

Audacity doesn’t “edit audio files”. Audio files are imported (copied) into an Audacity Project, and exported to create a new audio file.

The first thing I’d look at is the file names of the edited files. Valid file names depend on the file system. Some characters are valid on some file systems and not on others. Some file systems are case sensitive, some are case insensitive.

The second thing I’d check is that the “ftp user” has write permissions for the target location. Try uploading a non-audio file to the place where you are trying to upload the audio files to.

Thanks for the reply! Just tried deleting the previous versions of the files from the server, and the new files upload without a problem - obviously a server permissions problem (even though I have admin access to the server).

Thanks again!

This topic was automatically closed after 30 days. New replies are no longer allowed.