Audacity refusing to record when overdub is enabled

Distro: OpenSUSE Tumbleweed Linux: 5.9.1-1-default

Sorry if this has been asked before but I can’t find anywhere where it has. So I’m trying to record myself playing guitar while listening to a click track so that I can play more over it later, essentially overdub is essential to my projects.

When I press record when any other track exists it records for a very very small amount of time and then stops it. The only way I can get Audacity to record when more than one track exists is to disable overdub (which is not a good fix considering I really need it).

I’ve tried using all of the lowest sampling settings as well as lowering the Default Sample Format down to 16-bit, none of which had any effect.

Whenever this occurs I also get this error in the terminal

Expression 'err' failed in '/home/abuild/rpmbuild/BUILD/audacity-Audacity-2.4.2/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c', line: 3355
Expression 'ContinuePoll( self, StreamDirection_In, &pollTimeout, &pollCapture )' failed in '/home/abuild/rpmbuild/BUILD/audacity-Audacity-2.4.2/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c', line: 3896
Expression 'PaAlsaStream_WaitForFrames( stream, &framesAvail, &xrun )' failed in '/home/abuild/rpmbuild/BUILD/audacity-Audacity-2.4.2/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c', line: 4274

Again, sorry if the formatting here is wrong. I really need Audacity to work and soon (I tried Ardour and dear god please audacity just work lol)

sorry if the formatting here is wrong.

It’s OK. If we need more information, we’ll tell you.

Are you using a cloud drive connection? Audacity hates that.


Are you using PulseAudio (“Pulse”) for both the recording and playback devices in the Device Toolbar?
If not, try that.

Switching both to pulse seems to have worked! Thanks a ton!