Audacity recording whistling sound

I am using Audacity to record some old cassette tapes to CDs. I downloaded Audacity about 10 days ago and recorded several cassettes successfully last week.
However, this week I am unable to do. When I click on the record button, all I get is a ‘whistling’ sound, which occurs whether I am trying to record a cassette or not. I have attached a WAV file with this sound, although I have been exporting the cassettes as MP3 files. I have uninstalled Audacity and reinstalled it, but the same problem occurs. I have not made any changes to my speakers in my laptop. I am running Windows 10, and Audacity 2.3.3. Do you have ideas as to what the problem might be and how to solve it please?


How is the cassette player connected to the computer?

Make sure you’ve selected the correct [u]Recording Device[/u]. If you select “loopback” or “Stereo Mix”, etc., you can create a nasty feedback loop.

The cassette recorder is connected to my laptop via a USB connection.
I have the following selected -
Microphone Array (Realtek High
2 (Stereo) Recording Channel
Speakers (Realtek High Defin

I think these were the default settings when I installed Audacity.

The cassette tape plays ok if I connect headphones to the cassette recorder, so it is not the recorder or tape that is the problem. And as I said, it worked fine last week!

Microphone Array (Realtek High

That’s the microphone in your laptop. You should be recording from the USB device. It should say “USB codec” or “USB… something” and in some cases you may see the actual name of the device.

Worked out what I was doing wrong, thanks for your help in pointing me in the right direction as to what should be displayed for recording. I have been connecting the cassette recorder AFTER loading Audacity, rather than BEFORE (this week at least!) so Audacity did not recognise it.
I have therefore made notes as to what I should be doing.

Many thanks for your help.

Best regards, robine