Audacity Randomly Stops Recording

I’m undertaking the monster task of recording my vinyl.

What I’m using:

Technics 1200 MKII with Grado Cartridges, using RCA/Phono to a Rega Fono Mini ( USB A2D, using a 12 ft USB cable to a Win 8.1 x64 machine with 32 GB of RAM, and a Haswell i7 CPU.

I record at 16 bit 44.1K.

What happens:

Not all the time, but often enough to be quite annoying, all the sudden Audacity will stop recording. When you have 10 min songs and it stops 9 mins in-very frustrating. Most times it behaves like that, Audacity stops near the end of the song. I have to use play Software Play through to listen for skips, plus I haven’t heard many of these songs in a long time! :slight_smile:

What I have done to try to fix the issue:

I have tried 3 different USB ports. 1-thru a USB 3.0 hub, 2-thru a front panel USB 2.0 port, and just in the last few days 3-thru a USB 3.0 port right on the board-no difference.

I have also tried changing the interface, starting at MME, going to Windows WASAPI, but also trying Windows DirectSound-no difference.

I have tried checking both “Allow applications to take exclusive control of this device” and “Give exclusive mode applications priority” on the Rega USB device (which just shows as “UBS AUDIO CODEC”-no difference.

Lastly, I have tried playing with the Latency-Audio to buffer, starting with the default (can’t remember what that was), going to double the default, 500, now at 1000 ms-no difference.

You guys are my last resort!! If you need any other info, about my setup please let me know. I have a history of working in a recording studio, using Pro Tools-can’t use it for this, long story, and I’m not used to having this much difficulty!! Any help would be greatly appreciated!

Thank you.

Have you tried cold booting the computer? USB audio devices do not go on recording for weeks on end without that.

To cold boot, hold SHIFT while clicking the Shut Down menu option from the Start Menu, Start Screen or Win + X menu.

USB hubs will increase the risk of problems, as will long USB cables. So it might help if you can move the computer and turntable closer together.


Thanks Gale.

Can’t say I’ve done a cold boot as you describe, however I did unplug the PSU from the wall for a few hours when I was messing around with a GFX SLI in my box.

The hub actually worked just as well as any other USB port on the board, go figure. I guess I could try a shorter cord, but no one could walk in that area. :slight_smile:

Any other suggestions?

If you have an early (2013) Haswell, you could be looking at the Haswell USB3 bug.

If it’s a desktop, there’s an easy fix: buy a USB2 PCI card and use one of the ports on that card.

If it’s a laptop, there’s no known fix. In rare cases, it can be fixed by using a USB2 hub.

Then why not actually try it? Long USB cords and never cold booting the computer are two very good reasons you might get the problem you are experiencing. We should eliminate known, obvious reasons.


A different/shorter USB cable is certainly one of the things to try too. USB can be quite strange, sometimes.

So I tried the SHIFT+Shutdown, AND I’ve moved the turntable closer, guess we’ll see what happens.

Thanks all for the suggestions!

Unfortunately, the issue is not fixed. It seems better, but still randomly stops recording.

Oh well, I guess with a free app you can’t get everything. Overall, great app, but quite an annoying issue.

What makes you think the problem lies in Audacity? Does it work correctly with other software? What software was included with the Fono Mini A2D?

Have you tried a different USB cable?
Which version of Audacity are you using?

Admittedly I cannot do a different input vs output on Pro Tools, so I have not used it too much, but in my small experience it has seemed stable.

None, I’m afraid, it uses the “USB Audio Codec”, though funnily enough I did see it show up as the Rega… though that was only temporary.

Yes, went from 12 ft → 3ft.
Version 2.21.

Version 2.21.

Audacity doesn’t make a 2.21. There are bogus versions of Audacity out there with “funny” numbers.

You can get Windows Audacity 2.1.2 from here.
If you want to start “clean,” select Reset Preferences and Settings during the setup.


Doh! Sorry, meant 2.12. Got a bit of dyslexia there. :wink:

There’s something I meant to say at the beginning. I have wiped and re-installed Windows from scratch at least a couple times (it was kind of a lab system before doing all this), but again, unless I try another audio program I guess I can’t blame Audacity.

Do you or anyone one else, know of one that lets you use a different output from your input?

Thanks all for the help!

More dyslexia or do you have a fake version? There is no “two point twelve” version either.

You can use Windows Sound Recorder as an experiment. Fono will have to be the default recording device in Windows Sound.

There are plenty of other applications you can try. Goldwave has a free trial and lets you choose playback and recording device.

Once again, get Audacity 2.1.2 from here We don’t like you having versions we don’t make and are not able to help you with those.

Reinstall 2.1.2 from
and enable “Reset Preferences” half way through installation. Confirm you want to reset preferences when you launch Audacity.

If that does not help, Edit > Preferences…, Recording section and increase “Audio to buffer” above 100.


No, that’s just stupidity. :slight_smile: 2.1.2

Thanks Gale, appreciate it!

I’ll try the Windows Sound Recorder and some of the apps and see what happens.

Right now buffer is at 1000 :wink: