Audacity Plugin Download Issue

I use a mac OS X El Capitan 10.11.6 and Audacity 2.2.2. I am attempting to download the ACX Test plugin. Its downloading as a .txt file which is not executable. I tried pressing CNTRL and right click to save as a .NY file. There is no option to SAVE AS and select .NY, so I selected download as but there still is no option to change the file type. What can I do to download this file as a .ny filetype?

This is due to Apple “helping” you.
Nyquist plug-ins are written as plain text, so you can download it as a .txt file, then rename it and replace the “.txt” with “.ny” (just be careful that it does not end up with “.ny.ny”).

That and it’s ACX Check. (attached).

If you’re planning on reading for audiobooks, you should know ACX Check will get the background noise reading wrong if it can’t find about a second of background noise without performance or any other sounds. This is harder than you think. No shuffling or taking deep breaths. Freeze and hold your breath.

That background sound called “Room Tone” is also built into ACX submission standards.

This is a quick piece on creating a forum test clip. It’s just a short version of how you would be reading a longer work. This isn’t audiobook mastering. We have one of those, too.

Acx-check.ny (9.01 KB)

I’m afraid it didn’t solve the problem. It’s not downloading as a .txt file. I tried your attachment and it did the same thing. Any other ideas?


So it is downloading as a .ny file?
Where are you putting the file after it downloads?
– Bill

No, my file downloads as a .txt file.

kozikowski - I’m not sure how to respond to a specific person on this thread, but the file included on the kozikowski response worked for me. Thanks. Problem I still am unable to download other plug-ins. I have the same issue whereby I am unable to download or save the .ny file. (still getting a .txt file type) Any additional thoughts are appreciated.

This is a common problem on Macs. The Mac is changing the file extension. You need to change it back from “.txt” to “.ny”

I cannot save the file as anything other than as a plain text file ‘.txt’. The file is downloaded as .txt. I can then change the .txt to .ny but it is still a plain text file and not recognized in the plug-ins folder. All other plug-ins are ‘document’ file type. How do I change from plain text to document file type?

Yes, it is downloading as a .ny file and it’s going straight to my desktop, BUT the message I sent you earlier pops up.

You can force Macs to hide filename extensions and that can cause many of the same problems it does on Windows.

Are you set to show the whole name? (attached).

From the desktop > Finder > Preferences > Advanced.
Screen Shot 2018-04-06 at 14.04.54.png

UPDATE: I am now able to download the file and change the extension to .ny and activate for use as a plug-in in Audacity. Thanks for the input. Very helpful.

I am also having these exact issues and I do not know how to fix this. I’m using mac OS Sierra 10.12.6 and Audacity 2.2.2. ACX Check plug in turns to txt file. Even after changing it back to .ny. All help appreciated.

Ensure that your Mac is showing you the file name extension. It can get very confusing if the computer is hiding it.
See here for how to make a Mac show the file name extension: