Audacity Plugin and other Sierra issues.


I’ve used Audacity for years, I like the fact it is more simple and straightforward for stereo audio file editing compared to most other programs out there for things like normalization, compression, fade in, fade out, etc. I recently purchased FabFilter Total bundle, and was hoping to use their plugins with Audacity. I quickly learned of Audacity’s issues with Sierra, and find that even with some of the suggested workarounds, the plugin issues are too severe to make this work.

Does anyone know if there is a fixed release of Audacity for Sierra coming soon, and if so, an ETA? Are there any beta releases which work better with Sierra, one can sign up for now?

in the meantime, what other programs (commercial, I don’t mind paying if it works,. or free is fine) which have a simple editing interface like Audacity someone might recommend? I’ve tried a few of the expensive commercial products, and those I’ve tried so far have complicated and somewhat difficult to learn interfaces compared to Audacity, so wondering what someone might recommend as another choice to use in Sierra for simple stereo file editing along with plugins, until Audacity works better in that version of MacOS?


  • Jeff

Audacity 2.1.3 (available here: works fine for me on Sierra.
What “issues” are you referring to?

Hi Steve,

I tried using FabFilter Pro-EQ 2 with 2.1.3 yesterday. The first time I select and try to use Pro-EQ 2 during a session it comes up and seems to work. After that, though, I cannot select Pro-EQ 2 a second time. When I select it a second time, nothing happens, the filter doesn’t seem to open. I’m guessing it is related to the Sierra plugin issue that is described on the Audacity website, but maybe it something different?

I’m new to using 3rd party plugins with Audacity, also, so maybe I’m doing something wrong? Any suggestions? Can anyone reproduce the issue?


  • Jeff

Audacity does not support plug-in authentication (or “dongles”), which is a deal breaker for many commercial plug-ins. Some license authentication systems require interaction by the host application to verify that the plug-in has been “unlocked”. Audacity does not have the cryptographic code necessary to confirm or deny whether a plug-in has been licensed, which leaves many plug-ins in “demo” mode. For plug-ins where this is an issue, you will probably need to use a commercial host application (such as “Logic”).

I’ve not tested the FabFilter plug-ins, but I have no intention of spending hundreds of dollars, and I don’t like to clutter my machine with demo / trial applications.