Audacity only part imports the audio file.

Could somebody help me here?
Whenever I download an mp3 audio file for editing it only imports the first 7 minutes.
The audio voice recording is about six hours long.
I use the edit toolbar to import the file as raw data and in the pop up window the download % is set at 100 %.
is there any way that I can ensure that it imports the full 100%

Audacity made by us does not have Import Raw Data on the Edit Toolbar so I suggest you download Audacity from us:

Then just drag the MP3 into Audacity. Import Raw Data does not work for compressed files like MP3.

If the file still imports short, then it either isn’t really an MP3 or it’s corrupted. Try downloading it from another site or clearing the cache in your web browser or download manager and downloading it again.

If you still need help after that, download “MediaInfo” from Get the version without installer, because the installer may have malware or adware. Post the information that MediaInfo gives about the file.


look I will clarify all the details.
The computer uses windows 7 home premium.
The version of audacity is 2.0.6
When I press edit i scroll down to “import” then a side widow pops up with four options which read “audi” “labels” “midi” or “raw data”
Ther side window doesnt say “import raw data” as I think was assumed on my first post, it says “raw data”
So do I still have a genuine Audacity download on my PC ?
Lets start from here.

Oops I would also like to clarify another mistake on my post. I mentioned that i am importing the file by pressing edit which is wrong. Actually i am clicking on “file” not “edit” to scroll down to import and then clicking onto “raw data”.

Please read my previous post more thoroughly and act on it.

Drag the MP3 into Audacity using your computer mouse, or use File > Import > Audio… . Do not use File > Import > Raw Data… . Raw Data is not meant for MP3 files.

Where do the files come from? Try downloading them again, using your web browser, if that’s what you mean by downloading. If you got the files from a USB personal voice recorder, drag the files into the computer again.

If the file really plays for six hours in Windows Media Player but only gives you seven minutes of waveform in Audacity, please post what MediaInfo says about the file. Then we will know what type of audio the file really contains and should be able to offer some suggestions.


According to media info it describes the file as; MPEG 4 ( 3GPP Media Release 4 ). 433 mb 8h 5m
Overall bit rate 125 Kbps
1 Audio stream AAC

Thanks Gale Andrews .

I saw on another post that you suggested that I download the FFmpeg program to inport files
Well I did this and now I imported that large file that was causing me problems and I have edited it as well.
When I exported it back onto the audio libraries, it also converted the file into a WAV format .

This is brilliant thanks

Yes, MediaInfo shows you it was an MP4 and not an MP3. Now you have FFmpeg you can import MP4 files into Audacity.