Audacity now only showing "Pulse" & Default for recording?

Until recently Audacity showed the list of devices in both the record and the playback device selection lists. For some reason this has changed on my 2 Linux rigs, one running 3.2.5 and one running 3.0.2 .

This wouldn’t be too much of an issue if Audacity told (or could tell) PulseAudio to use the selected sampling frequency (and bit depth) but that’s clearly not the case. My 48kHz recordings sound a semitone too high, which corresponds exactly to Pulse serving data sampled at 44.1kHz …

Any idea what gives here? I’d like to bypass pulseaudio for recording (without installing additional libraries) but I can’t seem to find any instructions on how to do that.


I had problem with 3.3.1 …Project rate is not on front screen any more only set in Preferences.
The track rate is the imported rate not the playing rate.
The project playing rate is now shown bottom RHS of screen when playing
confusing you have to be careful what the settings are.
There is menu option to reset configuration and start again, in case something has been set incorrect

Or you can use the button for Audio Setup in the top tooldock and then select Audio Settings…

That’s a bit easier to get to than using preferences - they both do exactly the same thing.


Setting the project rate is just part of the problem. The problem I ran into is that the rate was set to 48kHz in Audacity, so my track had the expected 48k samples per second. But clearly the input device sent data at a lower rate (pulse’s default 44.1kHz) because apparently pulse does what it wants in this aspect.

As a result, I had a couple of tracks that basically played back 44.1kHz data at 48kHz rate, causing it to sound 8.84% too fast and too high. The tempo change is barely noticeable if at all, but the pitch change corresponds to 1.47 semitones, and THAT is noticeable.

The curious thing is that the day before I had made other recordings, also through pulse. That was because I got connection errors (error -9999 or some useless number like that) trying to use the device directly, because they still showed up. Those recordings are fine, so I have to assume that the failed connection attempt did manage to configure the correct sampling rate.
Between that day and yesterday’s botched recordings I shut down the machine. Maybe I should check if any updates had been installed between those two boots.

I’ve always disliked how pulse wants to know better about things like sampling rate, working with just 2 values behind the scenes. They’re not wrong that just about every common sampling rate is a multiple of either 44.1 or 48 but why would you burden the daemon with rate conversion if the destination device accepts the original rate of the content you’re playing? For recording it’s even worse, clearly…

To answer my question partly: on one of my machines the problem sorted itself by restarting the PA daemon (sending a SIGINT), so that gives me something to try next time I try to use the other system.

RJVB… Why are you blaming Pulse…??? Have you any other players that are affected or is it only Audacity.
As I sai in earlier post I had similar problem and the problem seemed to caused by the order that I was doing things when playing and editing… You could try this or similar as a simple test…

As a test…I am using windows 11 and Audacity 3.3.1…
Open Audacity… check prefs are at 44.1 for project and default, I also set recording to mono output.
Then generated track of a sinewave tone of 4 x 1 sec clips, 220, 440, 660, 880 joined as 1 track 4 secs.
Played this and checked pitch on tuner, all OK and exported as test2.wav. Using windows file manager properties checked bitrate was … 44.1 x 16 x 1 = 705.6 = 705 kb/sec. for mono.
Then closed Audacity and opened again and opened the test2.wav, it opened and shows 44100 on the track and when playing shows Actual rate 44100 bottom RHS screen.
I then went to Prefs. and set Project Rate to 48000 and left Default at 44100. The track still shows 44100 and when playing the Actual Rate at bottom of screen is 48000. Checked with tuner and pitch of each note is OK. So it still seems to play at 44100 even after Project rate is changed to 48000.
Now exported to file test2.48.wav, checked file bitrate … 48000 x 16 x 1 = 768 kb/sec.
Closed Audacity and open again, checked Prefs. were still 44100 both proj and default, and then opened test2x48.wav. Track now shows 48000 and file length still 4 secs long, also Audacity has itself changed the project rate to 48000 and default is still 44100. When playing the Track plays at correct pitch according to tuner and shows Actual Rate as 48000 at bottom of screen. So after saving the file at bitrate 48000 and opening it again in new instance it shows 48000 on the track and Actual at bottom screen is 48000 and it has changed the project rate to 48000. and one cycle if 440 Hz sine has 109 samples… 48000/109 = 440 hz.
Changed project rate to 44100 again and it shows as Actual rate 44100, track shows 48000 and plays normal pitch. samples per 440 wave now 100 again.
Then exported to test2x44.wav. The file bitrate 705 kb/sec confirms 44100 sample rate OK.

The fact on one machine I could restore direct access to the audio devices after sending pulseaudio a SIGINT is a good reason to suspect that that daemon has something to do with my issue. I’m also blaming it for not allowing me to control the sampling rate the way I want. That said, I don’t see how the way things work on MSWin has any relevance here.

Tonight I tried to use the laptop in question again, with a build of audacity’s git/HEAD from a few days back. I did get to select the audio device I wanted at first, but got the nr. 9999 error. Loads of output on the terminal but it looks like ALSA doesn’t allow Audacity (or other applications, like VLC) to connect to the devices directly. I am member of the audio group so I ought to be able to.

The PulseAudio daemon clearly can talk with them so it is beginnig to look like it takes exclusive rights to the devices.

“I’m also blaming it for not allowing me to control the sampling rate the way I want.”…What way do you want to control it.
“That said, I don’t see how the way things work on MSWin has any relevance here.” Sorry I probably should not have said Windows anywhere, but I conmmonly use windows sthat comes to mind first.
What I meant was check the properties of the exported saved file to see if its bitrate etc corresponded to what you think Audacity exported it at. …Audacity should export at the current Project Rate at the time of exporting and if you play the track just before exporting it will show as Actual Rate at bottom right of screen. All this does not matter whether it is Linux or Windows. The example in last post was only a simple example of creating a track, playing it, exporting it, see what bitrate the file actually has, then open or import the saved file into a new Audacity project and see if it plays at proper bitrate and pitch of sound is still correct. … Now you are introducing a 3rd party VLC. player. Does Audacity, Pulse and LInux all work together properly on their own. …???
Is the problem only when you try to play something on VLC…??
If you think Pulse is a problem… open the pulse volume control and see what you have got and try the options.
If pulse is causing a problem uninstall it and reinstall it.

This topic was automatically closed after 30 days. New replies are no longer allowed.