Audacity not responding and whiteout screen

I have put one long file into Audacity with the intention of splitting it into a number of separate track. The initial file is over Two hours long.
After splitting the file and moving to a new track Audacity freezes and a while later white screen with - Audacity is not responding. Only thing is to close and come back but I still can’t accomplish this stage one. Always occurs. I did get the whiteout screen also with another project a few times but not like this whereas I can’t even really start the project. This only since update to 3.2.1.
On a Toshiba laptop, Intel i3 Windows10 21H2.

Audacity 3.1 introduced non-destructive editing .
I believe the way that this feature has been implemented means that if you split your initial file, you’ve doubled the size of your project in memory: each half contains a complete copy of the original (unsplit) file. :open_mouth:
This means project sizes can grow far more rapidly than with the previous (destructive) editing system.
If you start with a 2 hour file you could rapidly run out of memory … Cannot continue using Audacity in its current state - #14 by steve

It’s not as bad as that. Audio data may be shared between multiple audio clips. It’s when the audio data is modified that a copy has to be made. Nevertheless, it’s true that projects made in Audacity 3.1 and later can be much bigger than in earlier versions.

I did some tests comparing 3.2.1 and 2.4.2 …

Test methodology

  1. Generate 2 hour stereo chirp
  2. Split into 24 5 minute clips
  3. select all and amplify
  4. select all and fade out
  5. Select all and Fade In
    Between each of the Steps I noted the active size of the project closed Audacity and noted the inactive project size and then relaunched.

at Step 1-2 the active and closed size was 2.4GB
for steps 3-5 the active size was 4.8GB, the inactive closed size was 2.4GB
Size of project at the end 2.4GB

At Step 1 the active size was 5GB (AUP3 and WAL both 2.5GB)B - the closed size was 2.5GB
At Step 2 the active size was 2.5GB AUP3, WAL 1.7MB - the closed size was 2.5GB
At Step 3 the active size was 5GB (AUP3 and WAL both 2.5GB) - the closed size was 5GB
At Step 4 the active size was 10.1GB (AUP3 7.6GB and WAL 2.5GB) - the closed size was 5GB
At Step 5 the active size was 7.5GB (AUP3 5GB and WAL 2.5GB) - the closed size was 5GB

For both the processing time for the generate and the effects is broadly similar with both versions.
3.2.x carries the extra burden of Compaction on closure which took c. 1min 10secs (twice as long as the effects took)

My conclusions are:
i) yes the 3.2.x smart clips result in a larger project size the the 2.4.2 simple clips (in this use case double the size when closed
ii) The on-disk size of a 3.2.x project can be much larger due to the temporary WAL file
iii) performance appears to not be an issue
iv) compaction in 3.x cab be both time-consuming and tiresome - but necessary due to the use of the SQLite database
v) 3.2.1 step 2 WAL size seems unexpected
vi) 3.2.1 step 4 active size was surprisingly large
vii) I’m surprised that the inactive/closed size of the 3.2.1 project does not get above 5GB. given that it has 24 smart clips each with a full 2 hours of data (albeit mostly hidden). I suspect that if I edited each clip independently and differently then the project may have grow even larger.


I suspect that if I edited each clip independently and differently then the project may have grow even larger.

No so actually it appears …

Once again in 3.2.1 I created a 2hour chirp but this time divided it in 12 clips of 10mins each - and applied different effects to each clip.

I ended up with a 5.11GB closed project - the WAL hovered around a further 252MB as I worked (so it looks like the WAL was dealing with each clip in turn).


One thing that is positively dangerous is resampling a long track that has a lot of clips.
Even with only 10 splits to an hour long track, the results are alarming:

  1. Generate a 1 hour chirp, mono, sample rate 48000 Hz, and Save.
    Size on disk = 667.9 MiB
  2. Create 10 splits in the track and save.
    Size on disk = 668.6 MiB
  3. Resample to 44100 Hz.
    This takes ages, even with a SSD.
    Size on disk = 10.5 GiB

(I initially tried this with 100 splits, but had to force quit to avoid crashing my computer)

You can do this even without resampling by just creating a new project, simply select multiple clips from a single track in the project and copy them separately to a new project.

OK, with a simple 1-hour 628MB project, I copied four different five-minute selections from the same original track to New Project. You might think the resultant project would be 54/60628MB = 628MB/3 = 210MB, but you would be wrong. The right answer is 2,512MB = 4*628MB. (Hey, this actually came out exact!)

Possibly, you mean splitting the track and moving to a new Audacity project? If you do this starting in 3.2 (possibly 3.1), the entire original track actually gets copies behind the scenes, presumably so that you could recover the original “smart-clip” audio, should the need ever arise.

A work-around might be to copy the partial track to a new track within the original project, then do Tracks > Mix > Mix and Render on this new track, then copy the “mixed” track to the New Project.

So, I cut the original 2 HR file I had put into Audacity at the 59 or so minute stage. Deleted the remainder from the project. Also deleted aup file of the deleted section from audacity folder. Still can not split and move to a new track within the project without the freeze and whiteout.
Task manager tells me no big deal with memory only SSD activity is through the roof.
Original 2hr aup file was 3.78 GB. 1 hr cut section is 3.55 GB.
I tried the same activity, bringing in a 1 hr file into Audacity to split into separate tracks and had no issues. This aup file for 1 hr 20 mins is 1.91gb.
So for my original attempt to slice the 2hr track and split into a number of other tracks within the same project is cancelled for now.
My only question now is, can there be a selection between the ‘non destructive’ edit method and a more non memory holding edit method?
If that is making any sense.
I wonder if Dark Audacity would enable me to carry out my simple project. ??

Or old audacity … Old Audacity versions download

Yes, I know. But the scale of size within a new Audacity project is quite simply ridiculous.
A 4gb aup file for a project which is initially 131mb with no effects, additions etc is a bit out of control.
I’ve probably offended many Audacity audiophiles here but it can be simply unworkable for a simple edit, cut, move project within the same project.
An option for destructive or non destructive edit facilities should be there.

Thanks for your report. We know there is a problem, and we are all trying to get a better handle on this issue. I have tried to reproduce your steps, above, but have differing results. When I generate a 2-hour stereo file and save it (Generate, 2-hour mono chirp, 2-hour mono DTMF, Make Stereo Track save, and close, I get a 2.5GB project. I then re-open, click near the 59-minute mark, Split (Ctrl-I), Add New Stereo Track, and drag the 2nd clip down, then all the way to the left. Then save and close. The project size had not changed. Clearly you are doing something different than I, but just what?

Fixed, But not solved!
So, I deleted the original 2hr aup file and anything else related to the project from Audacity. I made a small name change to my original 2hr MP3 file I’m trying to split. The file had (128kbs) in the title. I then gave it another go. Putting the full 2hr file into Audacity, making splits and moving the remainders further down to new tracks. It’s fine and cooperative! I can do my simple project. I have noticed the project rate is not 44100hz but for some reason the new project rate is 48khz. Also the size of the new aup file with no deletes on the original file in Audacity is now 3.12gb. as opposed to the previous 3.78gb so what’s going on with this is anybody’s guess. Anyway, it seems to be running fine for what I intend to do, for now.
Thanks everybody for your input…

You are welcome…