audacity not recording

Firstly I am no computer whizzkid, just learning through reading instruction/forums and trial and error:). I previously successfully used Audacity and my ION USB turntable to record LPs onto my now-defunct laptop. I have recently replaced the defunct laptop with Lenovo T440p with Window 8.1 but cannot record, When I set up LPs, I can hear the sound on the turntable but no sound records on Audacity. All I hear is a buzzing sound ?white noise, there is no waveform.

I have upgraded to Audacity 2.1.0 and followed the instructions re set up:microphone is set to USB codec, speaker is set to Realtek as listed on laptop, recording is set to stereo, I have tried available settings: MME, Windows DirectSound and Windows WASPI but none of them make a difference. I have tried adjusting the volume for recording on both Audacity and in Windows, does not seem to make a difference. I am sure I am probably making a very basic mistake but cannot work out what it is! Help please, thank you

re set up:microphone is set to USB codec,

That should have worked. It’s probably a driver problem.

Do you have any other USB audio devices connected? Have you connected a different USB audio device in the past? You may have to go into Windows Control Panel to re-install the driver or select a different driver… I had trouble with a USB microphone interface after using a USB soundcard. The Windows Control Panel said “This device is working properly”, even though it was not working properly.

(I believe you’ll have to use MME or Direct Sound. I think WASAPI in Audacity only works when recording “what you hear” from the computer’s speakers.)

I don’t have Windows 8, but there should be a way to listen to the USB turntable input without running Audacity or any other application. Windows has separate recording & playback mixers so you don’t always hear exactly what you are recording, but if you can hear the turntable through the computer that proves you can get audio into the computer through USB and you should be able to record it. (In Win7, there is a check-box in the Audio Control Panel that says Listen to this device. And on Win7, you get to the appropriate Control Panel by right-clicking the speaker/volume icon and selecting Recording Devices… I don’t know if that works on Win8.)

Loud white noise usually indicates a faulty or loose USB cable.

If you do have some other connected USB audio device (such as a webcam), then if you connected the USB turntable after launching Audacity, you need to restart Audacity or use Transport > Rescan Audio Devices at top of the Audacity window. Then you would have to make sure you choose the correct USB CODEC for recording device in Device Toolbar.

Alternatively disconnect the other device then restart or rescan.

In Audacity 2.1.0, WASAPI is available for physical inputs but it’s still regarded as somewhat experimental.

Yes, it is the same on Windows 8.1, but “Listen to this device” is never on by default in any version of Windows.

“Listen to this device” always has latency and imposes extra CPU usage, like Audacity’s software playthrough.


Thanks for the suggestions. I can now get it to work sometimes but not consistently. It seems to be the usb connection is at fault and as it is happening with all my usb ports, I assume it is the cable at fault so I’ll have to try and get a new one. Thanks again…