Audacity not Recording

I am using Audacity 2.0.5 and I downloaded and used the .exe installer.

The Set-Up I am having problems with is a electric Keyboard,
running into a E-MU 0404 USB Audio Interface, using two jack cables for left and right sound for recording in Stereo, each going into a separate input in the E-MU.

The Windows PC Is running Windows 7 Home Premium.

Now the problem I am having is that when I have the settings as;

Interface Host: MME
Playback: Speakers (Connected directly to the PC)
Recording : E-MU 0404 - Mic
2 Channel Stereo.

When I go to record the audio, the recording arrow and line in audacity just flashes on and off at the start of the stereo track.

However on occasion it does record, but this is very sporadic and rarer than it not recording at all.

In reply to some questions I am sure by responses I have looked at that’ll come up:

This happens whether overdub is on or off.

Software Playthrough is Off and always has been.

Sound Activated is Off and always has been.

Also I have checked in the Windows Sound menu, and the Speakers were set as default playback, and the E-MU Microphone (The only thing showing up in Audacity and Recording on the Windows Sound) as the default recording item.

Now occasionally when it doesn’t record it comes up with this Latency Correction Error Box.

If anyone can advise what the problem may be that’d be a great help. This exact (And It was exactly the same as far as keyboard/E-MU and roughly the Audacity settings were concerned) set up worked fine on the old Windows XP machine. but now it’s just doing this and I can’t find out what the problem is.

Make sure that you have the latest Web Install of driver, firmware and software from: .

Note that Creative do not claim the 0404 officially supports Windows 7, though someone recently reported it recorded OK in Audacity on Windows 7 as long as sample rates were set everywhere to 48000 Hz. So exit Audacity. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the 0404 then choose “Properties”. Then click the “Advanced” tab and check (tick) both “Exclusive Mode” boxes and OK all dialogues.

Open the E-MU USB Audio control panel (the icon should be in the System Tray) and set the sample rate to 48000 Hz.

Reboot the computer. Launch Audacity, open Device Toolbar and set host to “Windows DirectSound”. Set the project rate bottom left to 48000 Hz.