Audacity not recognizing my USB mike all of a sudden!

All of a sudden, my USB mike doesn’t record. Audacity recognizes it, but when I press record nothing happens–just silence. I’ve restarted, rescanned, tried the mike elsewhere to see if it works, (it does) but on Audacity --nothing. It worked fine yesterday–but today–nothing. What happened?

OK; so you’ve done Transport > Rescan Audio Devices, then you have repeated the Audio Setup. If it doesn’t work under MME, have you tried WASAPI ?

Also, sometimes the number of channels has to be just right.

Do you get an error message ?

So if worked yesterday on this same computer it unlikely you will need to check Microphone permissions.

No error messages–just dead recording. I know the mike works though, I’ve tried it elsewhere. Just nothing.

BTW, doesn’t work WASAPI either.

Which microphone?

Windows? Did Windows do an update in the background between the two dates?

Koz

Same problem here.

Did you try rebooting you computer ?

Yes, several times

Is it recording with me.
But it’s buzzing and I can hear my voice somewhere far away. The microphone is also recognized. But what do I have to set?

Hopefully, this resolves the issue: