Audacity not recognizing headphones?

I’m using Windows 10 and Audacity 2.4.2

I’m trying to record audio coming from my computer through my headphones, which I’ve done in the past
Recently, I closed down an audio manager popup dialogue from my computer asking “Which device did you put in?” when unplugging my headphones. I got tired of the popup so I closed it, checking a tickbox to “always select this option, don’t show me this popup again”

Now, when I go in Audacity my headphones aren’t showing up where they used to in WASAPI. It used to show Headphones (loopback) but now I just have Speakers (2-realtek high deifintion audio) and microphone. The audio still works fine on my computer as normal, I’m able to hear from my headphones. Although my headphones are recognised as Speakers (2-realtek high deifintion audio) on my computer.

I’m sure if I can get the popup dialogue back, it’ll fix the issue

Any help would be appreciated

Can you find the audio driver in control panel?
If you see it, get in and try to manage the settings at your favor.
I understood that your headphones are still working anyway, Right?

I can only see HD audio manager, and I can’t change any settings in it

My headphones are working fine

There should be an advanced settings tab somewhere or an “expert user mode” that will let you deactivate the sound devices detection.
I hope you to have that option because I have no more ideas.

Ok I found the popup message and clicked on Headphones

But Audacity still won’t record anything. My computer still reads my heapdhones as Speakers, but the audio works fine through the headphones

I had this issue before, but I remember all I did was download the latest version of Audacity and it solved it

Solved! I had audio on 1 mono instead of 2 stereo