Audacity not recognizing any input from USB mixer

My mic and guitar play fine through the mixer and to the speakers.

And Audacity was recording fine, and working as expected.

Just upgraded to 3.4.0, and now Audacity does not recognize the mic or guitar. It is recognising the mixer, as the output and the condenser mic as the input, project rate is 44100 Hz and I have MME selected - all the same settings that I used prior to the upgrade.

But for the love of god, I cannot get the software to work as it once did. I have tried mic privacy settings, looked at YouTube vids and support docs.

I am at a loss. Can anyone please help?

With MANY thanks !

As these are connected through the mixer, I would not expect to see them listed in Audacity - Audacity would show only the mixer (or something that corresponds to the mixer).

After you plug in your USB mixer, make sure you do Transport > Rescan Audio Devices, then reselect your recording device.

Older versions of Audacity are available here: Old Audacity versions download

1 Like

Hello Jademan

Yes I’ve done the rescan many times. Audacity is seeing the USB Codec device. That seems to be fine. But the recording level bar is not recording anything at all.

It really is very odd. B/c the older version worked fine.

So I uninstalled the latest versions and reinstalled the older version. Alas the same problem.

What has changed ???

So annoying.

Sometimes it is just a button on your mixer. Which one do you have ?

If you do [Windows-Key]-R, then “mmsys.cpl”, and go to the Recording tab, you should see a list of your potential recording devices, with a vertical meter bar for each one. Check that you are receiving an input signal from your mixer.

That’s a good point. Thank you!!

And I can see that it is not getting a signal from the mixer. Interestingly, I plugged in a Scarlett and that works fine. So for some reason, its the mixer source.

Im beginning to feel like the USB Audio CODEC driver is playing up. No idea how to fix that, IF indeed, that is the problem.

As the mixer is driving your speakers, it is likely just a button on your mixer.

Or possibly the mixer driver got updated?

Interesting Jademan, thank you for your time and help, I appreciate it. I will go back to the drawing board, reset everything and start from scratch.

Hi Stevelee, that is what I was wondering actually. I have a driver update facility, so I’ll run that. Thanks for your time!

This topic was automatically closed after 30 days. New replies are no longer allowed.