Audacity not recognising input 3 or 4

Hi there, Hoping someone can help with the following issue.

Currently running windows 10 and have a Behringer U-Phoria UMC404HD interface.

I’m trying to run three microphones, however audacity only picks up the first two inputs and cannot record the third. Ideally they would be on separate channels but don’t need to be.

Windows has access to the third microphone - it can detect sound coming in from all four inputs.

audacity has fully privacy access to microphones. Drivers seem all up to date.

It’s not the microphones, they work in other inputs.

I’ve tried changing Preferences > Devices > Host: to Windows WASAPi then recording to 4 channels. It returns the following error, regardless of how many channels I select "Error opening recording device. Error code: -9997 Invalid sample rate.

Any suggestions I could try would be greatly appreciated. tyia

Check that the sample rate for the device in the Windows Sound control panel, is the same for both recording and playback, and the same as the “Project Rate” in Audacity (bottom left corner of the main Audacity window).

Its possible that when you use more input channels there is a restriction on the maximum sample rate available. Try setting your default sample rate to something lower such as 44.1 KHz.

Thanks for suggestions. Still no luck.

Recording and Playback windows settings were different (mic was 48k, speakers 44.1k), adjusted them to the same and still no luck.

My default project rate was 44.1K. Lowering that unfortunately made no difference.

Bump. Any other ideas. Anyone?

Create a “Audio Device Info” file (see:
and attach it to your reply (see:

As I have said in answer to so many posts you should run mmsys.cpl and look at the tab which shows recording devices. Any device which is listed as plugged in and enabled should be selectable as an Audacity input device. If this is not so please post a screen snapshot of the sound recording devices window overlaid on the Audacity drop down. For example:-
In this dull example the top three items are just loopback of outputs, line in and stereo mix don’t list because they are respectively not plugged in and disabled.

Here is the audio device info file
deviceinfo.txt (15.6 KB)

I haven’t got any problems there. My UMC404HD is selectable, which has all three mics running through it. In that recording windows tab the third mic is detected (the little green bars rise). However the third mic doesn’t work in audacity.

According to that, “device: 42 - Microphone (UMC404HD 192k)”, which was selected in Audacity at the time that you printed that device info, is capable of recording 4 channels. It is the only option that is capable of recording 4 inputs (the “loopback” devices are “virtual devices” rather than physical devices).
Unfortunately the device does not say what sample rates are supported for 4 channels, or any other requirement for 4 channels.

Device ID: 42
Device name: Microphone (UMC404HD 192k)
Host name: Windows WASAPI
Recording channels: 4
Playback channels: 0
Low Recording Latency: 0.003
Low Playback Latency: 0
High Recording Latency: 0.01
High Playback Latency: 0
Supported Rates:

Selected recording device: 42 - Microphone (UMC404HD 192k)
Selected playback device: 6 - Speakers (Realtek High Definiti
Supported Rates:

What are the sampling rates, in the “Windows Sound control pane” set at for the
UMC404HD recording device,
UMC404HD playback device
Realtek High Definition playback device?

OK I think that narrows it down to an Audacity problem but I would try removing some of the other device and drivers, particularly the Realtek ones which have been shown to cause problems. Also as one error hints at sample rate issues try testing with device and audacity defaults set to a lower sample rate. It would also be useful to know if the problem is still there with ASIO drivers but I realise that you might not be able to compile Audacity with ASIO.

Sorry for slow response, floods knocked out power. If its not bushfires here its floods.

UMC404HD recording device - 44.1K
UMC404HD playback device - 44.1K (greyed out cannot change)
Realtek High Definition playback device - 44.1K

The realtek playback was 48k - changed to 44.1K - worked for like 1 sec then audacity crashed and same error continues now.

Well that solved one issue, but caused another. Once I installed the ASIO driver the recording and playback options changed. I now have two new recording options for IN 1+2 and another for IN 3+4.

The seem to work perfectly so I can get sound from input three now. The problem is that I can only select 1+2 or 3+4. Not all 4 inputs together.
Under recording channels where I could previously select up to four, now only has mono and stereo.

Have updated audio device info
deviceinfov2.txt (16.4 KB)

OK found a work around/solution. Steve it was actually from reading one of your other responses elsewhere so thanks.

I downloaded Voice Meeter - ran IN 1+2 as hardware input 1 then IN 3+4 as hardware input 2 - then in audacity selected Voicemeter as the recording device and all three mics are working now.


Hi! I have the same problem with Steinberg UR242 - Audacity (the latest version, but previous versions too) does not see inputs 3 and 4, only 1 and 2. All other daws (Ableton, Cubase) see them without any additional tweaking.
Audacity Inputs 2.PNG
Audacity Inputs.PNG

They are probably accessing the device via ASIO drivers.

Audacity cannot ship with ASIO support due to licensing issues, so you have the choice between MME, DirectSound, and WASAPI.
In Windows 10, “DirectSound” is emulated - it’s actually the same as MME but dressed up to look like DirectSound.

Currently you are using “MME” (as shown in the “host” setting of the Device Toolbar).
Try selecting WASAPI as the “host” and see if that works.

No, I tried all combinations, but it never worked. Usually, it was not a big issue for me, I used Audacity for fast recording of guitar ideas, it was convenient - no to load heavy DAWs for recording short ideas, but now I switched to stereo input 3/4, and cannot use Audacity for this purpose anymore :frowning:

I had the same issue, and I think its the DAW, which is limited to 2 channels, I tried in Rea.per and you have change input channels to the number you want

Check this out (not spam, but i cant upload imgs)