Audacity Not Exporting (2.0.2)

I am having an issue where Audacity WILL NOT export the edited wav file (overwrite)!!! I open a wav file in Audacity, and remove silence at BOTH the beginning and the end then tell Audacity to export the wav file overwriting the previous wav file, but when I open the wav file in another program, my changes ARE NOT there!!! the silence I just removed is STILL there!!

developers, I think it is time for a new version!!!

in fact, Audacity is creating phantom files if I export it under a different name!!! I added a 1 then a 2 then a 3, and the ends of the filenames and Audacity shows those files in the Audacity export windows, but windows explorer DOES NOT show them!!! EVEN AFTER a restart!!! Audacity still shows them though!!!

but those files DON’T show in the ‘import’ Window, just the ‘export’ Window shows them!!!


it’s doing that with ALL files too!!! including recorded ones!!!

I cannot reproduce this problem, so please try this test and describe in detail what happens in each step:

Try making a shot recording and Export it to your Desktop in WAV format and use the name “test” (without quotes) as the file name.
The file “test.wav” should appear on your desktop (by default Windows will hide the file extension so it may appear as “test”.

Now export it as “test1”

Now make the track significantly different in Audacity (for example, delete half the track) and export it as “test”.

Please describe precisely what happens, including any warning messages and exactly which buttons you click in what order.

Please STOP all this shouting in capitals. Thank you. Just try and answer Steve’s questions as best you can, then we can see if there is a problem or not.


Please look at Edit > Preferences, then choose Import / Export on the left ( ).

If you have selected there “Read uncompressed audio files directly from the original (faster)” then when you overwrite a file, your changes should be written to the original file name, but the original file itself which has the unchanged audio will be renamed with “-old” at the end. Audacity needs that “-old” file to read from, because your project is still reading from that original audio. Might that be something to do with it?

If you change the “Read uncompressed audio files directly from the original (faster)” choice in Preferences to “Make a copy of uncompressed audio files before editing (safer)”, then Audacity won’t create any “-old” files and your original file should still be overwritten with your changes.

Also be aware that Windows hides extensions for files by default, so if you have dots in the name of the exported file, Windows won’t see the file as having the correct extension. Please read this which explains the problem: .



I just reinstalled Audacity and told it to reset all preferences during install and then it works just fine…

Thank you. Resetting the Preferences in the installer may or may not have helped, though it is often worth trying.

Just to add that there is a known bug associated with overwriting files where the export doesn’t happen and there is no warning:

WAV and AIFF exports will fail without warning if you import a WAV or AIFF by > reading it directly> , delete the file and its track then export new audio to the same file name and location as the deleted file.

Do you think that is what was happening? It will only happen if you do all three of 1) deleting the original file, 2) deleting the track, then 3) create or import new audio then export to the same file name.