Audacity not adding plugin (error) [SOLVED]

I’m trying to add a plugin called “Time Machine”. But everytime I enable it and click ok a pop up appears saying “Effect or Command at C:\Program Files (x86)\Audacity\plug-ins\TL-TimeMachine.dl failed to register:” then the description says “Could not load the library.” Can anyone help? Please?

Is it 32-bit or 64-bit? Audacity (for Windows) is a 32-bit application so it only works with 32-bit plugins, even if you have a 64-bit operating system.

And, some plug-ins are not compatible with Audacity (or certain other hosts). That’s up to the plug-in developer.

If it’s this one: http://www.vst4free.com/free_vst.php?plugin=Timemachine&id=2068
Try the “Win 32 VST” version.
(I don’t know if this plug-in works in Audacity as I don’t use Windows, but one post on that page says that it does).

Okay, so I was gonna revoke this post because I figured it out 2 minutes after posting this, sorry it took so long! So I was looking at other posts and saw that Audacity took only 32-bit, not 64-bit. And I was putting in the 64-bit, because I thought since I had a 64-bit computer, Audacity could too! I was wrong. I downloaded the 32-bit and put it in and Audacity took it in. Sorry for the issue!

Excellent. Thanks for the update.
I’ll close this topic as “solved”.

Since this thread was made, Audacity has become 64 bit. The constraints still remain the same though:

  • 64-bit Audacity only can handle 64-bit plugins
  • 32-bit Audacity only can handle 32-bit plugins

Also, note that some plugins can crash Audacity. These days, Audacity automatically checks whether they do and automatically disables crashing plugins. If it gets misdetected and the plugin works anyway after manually enabling it (via Effect → Plugin Manager), please make a bug report.