Audacity neither records nor plays

Audacity 2.0.5, .exe installer, Windows 7
For the last two weeks, Audacity has stopped recording new audio or playing existing project files. I can load the application, load existing project files, but once the file has been loaded, if I press “Play” nothing happens and the entire window becomes frozen. I have to force-close the application. Does anyone have any ideas as to what might be causing this? Until two weeks ago, Audacity was working fine.

Assuming you see the blue waves when you open the project, it sounds like your audio device is broken or not connected properly. Are you using the built-in computer audio device for playback/recording or a USB audio device? If it is a USB device, get a new USB cable for it and ensure it is connected tightly both ends. Connect it to an empty USB port on the computer, not to a USB hub that has other devices connected to it.

If you are using the built-in audio, have you changed its audio drivers just before the problem started, or was there a Windows update for your audio device? If so you could roll back to the previous driver in Device Manager. See Updating Sound Device Drivers - Audacity Wiki . If the drivers did not change, make sure you are using the latest audio drivers supplied by the computer maker (if it is a branded computer like Dell or HP), otherwise make sure you have the latest audio drivers supplied by the motherboard manufacturer.

If the problem persists after verifying the audio drivers/audio device, you could reinstall Audacity and enable the option to reset preferences half way through the installation process. See Audacity Manual .

If you don’t see the blue waves when you open the project (you just see a flat line) then Audacity cannot read the drive the project is on. It could be a problem with the drive or you may not have permission to read that location.


Thanks for the suggestions, Gale
I do see the blue waves. I will try your suggestions and let you know the outcome. However, I can play MP3 tracks via iTunes. Would this indicate it is unlikely to be an audio driver problem?

Yes it could still be an audio driver issue. Audacity records as well as plays, and needs the audio device to be working completely properly.

Also Audacity can choose its audio devices, so you may have been choosing a device in Audacity other than the Windows default device that iTunes uses.


Hi Gale

I have updated the drivers - incidentally replacing the Microsoft drivers with the Conexant drivers that were there originally - and reset the preferences on Audacity. Unfortunately, neither has cured the problems. I still get the problem that if I try to play an existing project, the window freezes. I haven’t re-tried recording.

Anything else you can recommend?


So did you “roll back” the drivers to the original Conexant drivers in Device Manager?

Microsoft generic drivers are almost never as good as the correct drivers intended for your motherboard audio. If those Conexant drivers behaved correctly in Audacity before, they ought to do so again, but to be completely sure you should download the correct audio drivers for Windows 7 from the motherboard or computer manufacturer if you have not already done so. Uninstall the current drivers (even if they are the same as the ones you downloaded) then install the downloaded drivers and reboot.

If you need help, please give the make and model number of the computer and state if you have Windows 7 32-bit or 64-bit.

You could also try performing a system restore back to a restore point created before the problem happened.

Are the projects located on a fast local hard drive? If the projects are located on a slow network drive, that could explain the problem. You may need to wait before Audacity responds.

Otherwise, open a project, then don’t play it but post the contents of Help > Show Log… , Help > Audio Device Info… and post your audacity.cfg file.

For the Log, click “Log” top left of the Log window and save the file. Please see here for how to attach files: .

For Audio Device Info, right-click > Select All then right-click > Copy and paste into your message.

The audacity.cfg file is at UsersAppDataRoamingAudacity . You may have to show hidden files and folders in order to see AppData.


Hello Gale
Sorry for the delay in responding - been away. The Conexant drivers were downloaded from Toshiba (its a Toshiba Satellite laptop).
Audacity projects are stored on my internal hard drive.
I have attached the files you asked for.

Once again, many thanks for your help with this.
audacity.txt (2.68 KB)
audacity log.txt (1.2 KB)
audacity audio device.txt (4.23 KB)

Try setting the Output (Playback) device in the device toolbar to “Microsoft Sound Mapper - Output”.
Does that work?

You should certainly choose the “MME” host in Device Toolbar if you are experiencing problems. It should be the most compatible host.

If the problem persists I would definitely uninstall and reinstall the Conexant drivers, then reboot.

Also consider system restore.


Many thanks, everyone. My problem is now resolved

What fixed it? Reinstalling the Conexant drivers you obtained from Toshiba?