Audacity macro-palette pushes around my shortcuts on a regular basis. [CLOSED]

I have no before picture, but sometimes I normalize an album and Audacity feels like pushing around my shortcuts in an arbitrary

In this case it looks like from a Tetris game. Other times it sorts it in a different way.

I just “upgraded” to 2.3.2 and hope this bus is fixed.

Otherwise I am forced to downgrade to 1.5 or some version like this, since they work perfectly fine and don’t do funny stuff like this.

Can you give steps to reproduce this problem?

What do you mean by “macro-palette”?

It’s the top menu item in Tools > Apply Macro

It’s the floating palette of available macros.


That’s also my assumption, but that floating palette does not interact with my Desktop icons in any way. Does it for you?

I’ve never experinced that when using the palette - which is not often, only when I was testing Macros for James a couple of releases ago.


On older versions of Windows I used to sometimes get annoying re-arranged desk-top items - but I never thoght Audacity was the culprit (and still don’t) - but I could never find a way to provoke it on my PC. I have not experienced suchlike for a while now.


Just found out that I can reproduce this bug by that green arrow on the top.
There is a slide that allows you to place the song slower and faster (how can you switch between those two pitch modes by the way?).

I tried to play a song very slow and very fast and Audacity did it again.

There are two kinds of pitch AFAIK.
The one slows down in duration and pitch and the other one keeps the pitch but sounds metallic.

I won’t regularly come here anymore to check if somebody posted a solution.
If something really happened, contact me via e-mail or something like that.

You can subscribe to this topic by clicking the spanner icon at the bottom of the page, then select “Subscribe” so that the check box is NOT ticked.
When subscribed, you will receive email notification when there are new replies.

I can’t reproduce your issue using that transcription toolbar play green button.


Just happened to me again. =)

So we know that like 20% of users experience this and 80% of users don’t experience this with this kind of data rn.

This time it happened during exporting vinyl recordation that I made.

So I guess in the end I can reproduce that error and bug in the future with more and more functions.
Which means in a month or so I just need to open up Audacity and it will shuffle my shortcuts on my desktop in that strange
upside-down position.

Noice. Let’s see if this works.

Do we?
How do we know that it not more like 0.0001% of users that experience this and 99.9999% of users don’t?

There’s some possible fixes in this topic: Desktop icons moving on their own! | Tom's Hardware Forum

I don’t know if this also applies to Windows 8, but it looks like a good possibility:

If using windows 7 right click on the desktop go into personalize, click on change desk top icons on the left of the screen, a new box opens un-tick the Allow themes to change desktop icons box… problem solved.

I sincerly hope that this is not the case.

I have Windows 10 right now.
I will use that

So far I did everything mentioned in the forum.
As far as I don’t respond in the future… the problem is somewhat solved…?
Thanks so far.

How is that?

I did check disk for my Windows 10, deinstalled Audacity, ran CCleaner, installed newest Audacity version and
now I have to “wait” until the error appears again.
If I have to wait forever, that means that the problem is fixed.
So I’m kind of trapped in an infinite uncertainty that I fixed it completely.
As long as it doesn’t appear again I’d say the issue is resolved and I’m happy.
If anything goes wrong, I will let you guys know of course.

Thanks for the update.
I’ll close this topic for now. If the problem reappears, just start a new topic and add a link to this one (In “Quick Links” near the top left of each page, there’s a link to “Your Posts” so you can easily find your old posts).