Audacity keeps freezing

I have a Windows 7 Lenovo Laptop. I got audacity with the .exe installer. I have Audacity 2.1.0. (Do you need the “Audacity”, “Build Information”, or the license section? Or all of them?)

So I’ve had Audacity for about 2 years now. I got the newest version about a week ago. Everything was absolutely fine until today. I imported a sound file and it worked. I was editing it, then it happened. Audacity froze. I couldn’t move the selection bar tool on the track. I tried to move it to the beginning of the track, but it did nothing. Next I pressed the record button, and it showed that I clicked it, (The animation where it looks like it presses down like a normal button,) but it didn’t record. I pressed the playback button, (or the play button, whichever you prefer.) but yet again, it did nothing. The play button didn’t even show the pressing animation.

The weird thing is, if I go into the Transport tab, and press record, it records. And if I go into the Transport tab again, and press Play/Stop. But it doesn’t want to work in the main area in Audacity.

When I pull up the Task Manager, (or for that matter, any other page or tab I have up,) everything looks normal. That is, until I actually click something. If I do click anything, it freezes up again. Except for the ONE thing that I actually clicked. It shows that I clicked it, but does nothing. Not to mention that my mouse still works when it does supposedly freeze up. If it’s a tab however, it will act normally. It will let me go to any of the tabs, unless I click the main area or ANY of the other buttons,(Not including the tabs.)

Please help me figure out why it’s doing this and fix it so it stops acting really weird.

Thanks, Ethan

How long is the show? Every time you do something, Audacity has to build an UNDO the same size as the show. If you’re running out of drive space, Audacity won’t have enough space to put things.

If you import an hour MP3 show, Audacity uncompresses it into a huge WAV format at very high bit depth. And then saves them repeatedly as you edit. Particularly if you’ve been doing this for a while, you may have run out.

Are you using USB drives or Network drives? They can have similar problems. Audacity doesn’t like running over a network.


It was only a 10 second audio clip. And I’m pretty sure it’s not a network drive. And I doubt it’s a usb as well.

Wherever you got Audacity from, go to then download and run the Audacity installer. Halfway through the installation, ensure you put a tick (checkmark) in the “Reset Preferences” box.

Before launching Audacity, right-click over audacity.exe (the installed application) then choose “Properties” then the “Compatibility” tab. Make sure Compatibility Mode is either off or enabled for Windows 7.

When you launch Audacity, say “Yes” when Audacity asks if you want to reset preferences. This should set Audacity’s temporary directory to C:\Users<your user name>\AppData\Local\Temp\audacity_temp.