Audacity keeps freezing when trying to edit added audio file

My project keeps shutting down every time I add an mp3 file of audio to my project. It’s preventing me from going any further. I have to shut right out because my operating system tells me that Audacity “is not responding”

Need help as I’m trying to work through the basic editing functions and it won’t even allow me to move the time shift tool. It’s really getting annoying and I’ve been told that Audacity is the right platform to be editing my audio files for my podcast

What version of Audacity are you using? Have you tried importing a different MP3 file or an AIFF file?
– Bill

I’m using version 2.3.3 … It’s a piece of music I purchased.

This is the error I keep getting … and it says it’s not responding, so I have to kill the project
Screen Shot 2020-04-28 at 7.40.52 am.jpg

Have you tried importing a different MP3 or AIFF file?
– Bill

Yes unfortunately … and it seems to only be music related files. Not sure why

I don’t understand “music related files”. Do other MP3 files import properly?
– Bill

Yes they do

So the problem is with the file you are trying to import. You purchased it? It may be copy-protected.

– Bill

I downloaded the new version today, and am also experiencing that Audacity freezes when I try to edit with two files open. As soon as I press play on the second file, the file freezes (other open file still works okay). I need to quit Audacity entirely and relaunch the application, but it keeps happening, so now in order to copy from one file into another I am having to quit and relaunch each time. Both are wav files that I created myself so they are not copy-protected.

I can’t reproduce this on my iMac with Audacity 2.3.3.

Please reset your preferences according to these instructions:

– Bill