Audacity keeps crashing

Hey, so I have been using the latest version of audacity on Mac Mojave (10.14) for a few weeks, and it’s been working with no problems. Today, I was trying to edit a clip, and every minute or so I was getting a “debug report” which would then freeze my mouse and I’d have to force quit. I deleted the .cpg file but it didn’t fix the problem. Then, I tried uninstalling and reinstalling audacity, and now every minute or so the program is just crashing with no debug report. I didn’t make any changes to my setting, and I was working on something just earlier this morning and didn’t have any problems!

Any help you can give is much appreciated!

What is the version number in “Audacity menu > About Audacity”?

Hi, all,
I’m having this same problem. I’m using OS X El Capitan, version 10.11.6. Have a podcast completely edited in Audacity and has been working fine. But when I go to edit a music track at the front of the audio clip – about 27 minutes in total – Audacity keeps bringing up the “debug report” and crashing on me. It’s happened three or four times now. Any ideas/tips are very welcome. Much appreciated!

P.S. It seems now I’ve lost the entire podcast. Audio levels are flat in the project when I open it up again.

I’ve downloaded a new version of Audacity: 2.4.2, but am a little hesitant to dive back into editing for fear I will lose it all again… Thanks for any and all tips! First time using the program.

What is the project’s sample rate ?

Do all the tracks have the same sample rate, and are they the same as the project sample rate?

– Bill

Hi, Bill,
Thank you for the question!

The project rate is 44,100.

The music file that I was editing is 44,100 and stereo.

But the three other tracks, recorded audio from Zoom, are 32,000. They are also mono.

Hi all,
It eventually worked but now I’m editing another episode and it’s happening again. It happened right after I imported the music selection, which is a .wav file. I can edit without the music just fine. Any ideas? Thanks in advance!

Just lost all of that episode after the recovery failed as well. Second time this has happened with as many episodes so all ideas welcome. Thanks, all.

If your project contains any tracks that do not have a sample rate of 44100, resample them to 44100 (“Tracks menu > Resample”).

Let us know if that makes any difference.

Not to keep posting but just an update. I’m now unable to edit anything with the music and the audio recorded from Zoom. I see an error report every time. First the debugging screen, then the error.

Hi Steve,
Thanks for that. I just imported the tracks that were not 44100, but then resampled them to 44100, saved and then imported the music tracks that are 44100. But got the same result – debugging screens, etc.

Perhaps you can send us that ZIP file. It “may” give some hint to why you are getting this problem.

Unfortunately Audacity freezes and I have to force quit before the zip file can form. I have now changed the project rate at the bottom of the file as well, so maybe that will do the trick? We will see. Any other ideas? Thank you very much!

Knock on wood… I just edited a podcast without it crashing! I changed the rate of the audio right after importing them, so perhaps that does the trick? Appreciate all the help very much.

I think you’re right. The problem appears to be this recently discovered bug: