Audacity K.O. on Debian - now compiling problam - need help

Hi group, my first visit is because i was running audacity for years on Debian unstable (3.13-1-686-pae #1 SMP Debian 3.13.10-1 (2014-04-15) i686 GNU/Linux)
since a couple of months after upgrading audacity stopped to work - not even an error - you write ‘audacity’ as usual and you get prompt.

I’ve tryed many solutions (ubuntu repository, downgrade etc.etc. ) in short now all goes in directions of DL sources and compile - (which i normally don’t like - if possible better have a consistent updated system)…

Ok then aptitude build-dep audacity
got sources from git

that’s the error:

WaveClip.h:58:17: warning: passing NULL to non-pointer argument 1 of ‘std::vector<_Tp, _Alloc>::vector(std::vector<_Tp, _Alloc>::size_type, const value_type&, const allocator_type&) [with _Tp = long long int; _Alloc = std::allocator; std::vector<_Tp, _Alloc>::size_type = unsigned int; std::vector<_Tp, _Alloc>::value_type = long long int; std::vector<_Tp, _Alloc>::allocator_type = std::allocator]’ [-Wconversion-null]
AudacityApp.cpp: At global scope:
AudacityApp.cpp:239:13: warning: ‘void wxOnAssert(const wxChar*, int, const wxChar*)’ defined but not used [-Wunused-function]
static void wxOnAssert(const wxChar *fileName, int lineNumber, const wxChar *msg)
Makefile:2653: recipe for target ‘audacity-AudacityApp.o’ failed
make[2]: *** [audacity-AudacityApp.o] Error 1

Any help and any solution appreciated (getting .deb package that works, compiling, other software that works very similar, etc…)- thanks in advance!

How desperate are you?

Audacity is upgrading from WxGtk 2.8 to WxGtk 3.0 so right now the source code is highly volatile and problems are expected. All being well the release date is due somewhere around September.

You could try building the Audacity 2.1.1 release source code, but note that this requires WxGtk2.8 (WxGtk3 is not supported), so ensure that you have libwxgtk2.8-dev installed.

Hi Steve and thanks for the rply:

:slight_smile: “desperate” ist funny - i had to laugh! I was pretty sure it is a library issue - you confirm it.
Waiting till September should not be a too big problem, but in fact i have to edit some live made audiofiles… can you suggest an intermediate solution?

Beside this - i don’t understand why some software like audacity cannot get in the mainstream of debian or ubuntu flow and be always synchrinized with libraries… ???

Bob J.

I just removed libwxgtk3.0-0 and installed libwxgtk2.8-0, - but now worse:

configure: Checking that the chosen version of wxWidgets is 3.0.x
configure: error: Unable to locate a suitable configuration of wxWidgets v3.0.x or higher.
The currently available configurations are listed below. If necessary, either
install the package for your distribution or download the latest version of

Default config is gtk2-unicode-release-2.8

Default config will be used for output

Alternate matches:

Feel free to petition the distribution maintainers :wink:

well this particular update is one that we have been putting off for as long as possible because it is a huge job and we have a limited number of developers. The Audacity package maintainers for Ubuntu have been trying to patch up Audacity to work with their later version of Wxgtk, but really that has been an impossible job without a full scale upgrade, which they do not have the resources to do. Many distributions (including Debian stable) have now dropped Wx2.8 from their repositories, so for Audacity it is time to bite the bullet and update to Wx3.

You will lose some performance, but you could install a light version of Ubuntu (such as Xubuntu or Lubuntu) in Virtualbox, and add this repository:

The current development code requires Wx3.
The Audacity 2.1.1 release (and earlier) require Wx2.8

The release tarball for Audacity 2.1.1 is available here:
apt-get build-dep audacity will probably pull in the wrong version of Wx, so if you use that you will need to completely remove the Wx3 dev packages and install the Wx2.8 versions.

I, for one, can’t wait for the wxWidgets bug fix to take place. I currently can’t open Audacity, and I haven’t had success in installing the previous wxWidgets version.

Maybe the older version should have been kept available so that those of us who updated to Jessie wouldn’t end up without Audacity! :wink:

Hopeful for the new release in September…


Some distributions did that (example, Ubuntu), but Debian decided not to. I don’t know enough about this to say which approach is “best”, but I have run into compatibility problems when having both 2.8 and 3.0 installed at the same time, so there are certainly pros and cons both ways. Fortunately this problem will resolve itself in due course as everyone updates to WxWidgets 3.x.
Unfortunately there are many compatibility issues between WxWidgets 3.0.x and 3.1.x :frowning: How the Audacity developers are approaching this is to develop Audacity against Wx3.0 (the official stable release version of WxWidgets), and fix as many Wx3.1 issues as possible along the way, so as to minimise breakages when Wx3.1 is released.

What version of Audacity are you trying to use and where did it come from? What terminal or other error messages do you see?

Could you open it before you attempted to build wx 2.8?