Audacity is super slow

I’m on Windows 7 SP1 64-bit on a zippy i7 Dell laptop.

I needed to use Audacity today for the first time in a while, which was when I noticed that I needed to upgrade from 1.3.x to 2.0.2, which I did using the .exe installer.

2.0.2 loads fine, but once I import an an hour long mp3 for editing, it becomes unusable.

If I select a 10-minute chunk of the audio and hit the delete button, Win7 says that Audacity is (Not Responding) for at least 30 seconds, before finally refreshing without the deleted chunk.

If I click to zoom, it takes 10 seconds (I counted) before the window refreshes with the zoom, although I did notice that the more I zoomed in, the quicker Audacity reacted.

Is anyone else seeing this?


How much memory do you have? How may other applications and services were running?
This may be a problem with the 32/64 thing. Why did you notice that you had to upgrade?
This isn’t a fresh install of WIn7, right? It’s an upgrade?


Unfortunately, yes. See the Release Notes (search the page for “slow” and “delays”): .

Does your computer meet the Audacity recommended system requirements according to whether you have 32-bit or 64-bit Windows 7: ?


@Gale: The recommended system requirements for Win7 64-bit are 4 GB of RAM / 2 GHz, and that’s exactly what I have on my machine.

@Koz: There was about 1.5 GB of RAM available when I ran Audacity with the slowness. When I launched Audacity 1.3.x earlier today, I had a hunch a new version had come out at some point, so I checked, confirmed and then upgraded.

This machine was bought 14 months ago, has only known Win7 and the OS hasn’t been reinstalled since I got it.

There may not be much you can do. The slowness problem crept in about half way through the Beta series as a result of a number of changes (mainly to improve project recovery).

Changing the Default Sample Format in Audacity’s Quality Preferences to 16-bit might help - it halves the data Audacity is trying to handle.


That made a BIG difference.

Thanks Gale!


Actually, I found a simpler solution. I upgraded from Windows 7 32-bit (where Audacity worked fine) to Windows 8 64-bit, where I experienced the gut-wrenching slowness described above. I found that configuring Audacity to run in compatibility mode fixed the problem.

Just right-click on the EXE or on a shortcut to the EXE, select the Compatibility tab and select (in my case) Windows 7. Worked a treat. If you’re on Windows 7 64-bit, maybe you need to select Windows XP SP3 from the compatibility drop-down.


thanks for this

Thanks - jshare was on Windows 7 64-bit when he posted the first time.

I’ve not seen any evidence compatibility mode helped before, and don’t sense any difference on my 64-bit laptop (2.4 GHz, 6 GB RAM) between Audacity 2.0.2 on Windows 7 and Windows 8. Are you (SJWalter) working with very long projects (an hour or more of audio)?

I am not on Windows 8 at the moment but on Windows 7, you have to first choose “Properties” after right-clicking on the EXE.


No, I experienced the slowness on very small files.
Good news though - I just installed Audacity 2.0.3 which works just fine with compatibility mode switched off.