Audacity is recording with interference sounds and I cant record unless is with built in.

So. this is my first time posting and I hope I can make myself clear.

I have been recording without a problem.
2 days ago I recorded with two mics and I had to make some adjustments with the Audio MIDI, I had to createan aggregate so it would pick up both mics. I have an xlr mic with a phanton power connected and then it connects through the USB port. As I said no problem at all ever.
Now today I tried to record again with just one mic and its not happening.
When I press record instead of just a flat line it shows like something is recording when I click to playback its just an interference noise.
Help me please!

Please describe you setup in detail. Which microphones (make, model, connection type), interface devices, etc. Details about your aggregate device.
When you try to record with one microphone, what do you see in the Audacity Device toolbar? Do you see your single microphone? Have you tried Transport > Rescan Audio Devices?

– Bill