Audacity is installed - but I cannot open it

Audacity #
Windows 7 Service Pack 1
Tried to run Audacity (it had worked previously several months ago).
Nothing happened - no error messages, no sign of the program.
Eventually got an error message that the program was already running & I could not open it twice.
Removed & reinstalled the program - same results.
Tried the zip version - same result.

Task manager shows that Audacity IS running - end process, re-start, same result!
Tried un-installing, re-installing, re-booting - still the program refuses to open.

Just reinstalling it will make no difference.
Try rebooting the computer and then reinstall and in the “Select Additional Tasks” screen, put a check in the “Reset Preferences” box. Complete the installation. On launching Audacity, a dialog will appear where you can confirm if you want to reset preferences

Many thanks for your reply - I was about to do as you suggested, but first wanted to check that Audacity had been removed from my system.
It is NOT listed in the Control Panel> Programs & features list - but Audacity IS still on the Start button - “C:Program Files (x86)Audacityaudacity.exe”
Do I need to remove this before re-installing as you said? If so - how?
Confused & grateful for any help!

I don’t use Windows myself, but Google came up with this:

I have attempted to delete ALL traces of Audacity from my computer, re-booted & re-installed.
The same problem persists ie the program will NOT open to use, - but it is running if I start Task Manager.
Any other ideas??

Did you reset preferences?
When you attempted to launch Audacity did a dialog will appear asking you to confirm if you want to reset preferences?
Does your computer have a working sound card?
Are you able to record with Windows Sound Recorder?

Hi Steve
I think you may have identified the problem!
I just tried sound recorder & it would NOT open (I have used it in the past)
Also another program I use a lot (PhotoStory) would not play (that was working until 2 days ago)
SO I guess I must have inadvertently ‘knocked’ something essential off the system whilst un-installing & re-installing Audacity!!

Media Player & CD’s work fine, video presentations I have made work fine, Windows system sounds work fine, You Tube presentations work fine.
So it is not the sound card. Question is - what have I done & can you throw any light upon how I can correct it???