Audacity is already running error and no lock

OS X EL Capitan mac version 10.11.5 is my computer
Audacity I dont know cause now I got the message: Audacity is already running - error
and I have tried the forum - 2015 where it was solved but I had no file “audacity-lock-” at all so what shall I do?
I work with audacity A LOT and need it desperatily…

Please give me some developing answers. :unamused:

The lock file, if it exists, should be visible in Audacity’s temp folder, depending on your Finder settings.

The lock file would be visible from a terminal, regardless.

Please download the latest Audacity 2.1.2 from 2.1.2 might solve the problem because it will try to use a different default temporary directory ( /Users//Library/Application Support/audacity/SessionData ) than 2.1.1 and earlier.

Before launching 2.1.2, delete the entire /Users//Library/Application Support/audacity/ folder. That should start you out with clean factory settings, assuming you have not created a “Portable Settings” folder alongside Audacity. If you have, rename that “Portable Settings” folder.


Sorry that part is not correct. We did not make that change for Mac until July, in 2.1.3-alpha.

If using that new SessionData temp folder helps, then you can obtain 2.1.3-alpha from the top of 2.1.3-alpha is not a finished version. It has a lot of bug fixes compared to 2.1.2 but may also have some new bugs. You should still delete the entire /Users//Library/Application Support/audacity/ folder before trying 2.1.3-alpha.