Audacity hung on recording


nearly everytime i try to record somethind with audacity, the program hun and isn’t responsible anymore.
I have a realtec ALC 889, but for recording i use a logitech webcam.
Input Device is set to USB Device 0x46d:0x825: Audio hw(2,0): Frone Mic

Error Message in console is:

Expression ‘paTimedOut’ failed in ‘src/os/unix/pa_unix_util.c’, line: 387
Expression ‘PaUnixThread_New( &stream->thread, &CallbackThreadFunc, stream, 1., stream->rtSched )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2998
Expression ‘pthread_join( self->thread, &pret )’ failed in ‘src/os/unix/pa_unix_util.c’, line: 441

Sometimes it works when i swich to another input and back again.
My yystem is Linuxmint 18 Cinnamon

You could start by checking the tightness of both ends of the USB cable then rebooting the computer.

Then please tell us your Audacity version number (all three numbers) and where you obtained it. See the pink panel at the top of the page.

I assume you mean Front Mic not Frone Mic. Have you checked on the Linux Mint forums if this webcam device is class compliant or if there are special drivers for it provided by the community? You will need to give them the exact model number of the webcam.

Also turn off Transport > Software Playthrough in Audacity and you could try increasing the “Audio to buffer” value in Recording Preferences if the problem persists.


HI, thanks for reply
USB Connection is fine, i never had any issues using the webcam + mic in skype or qtox. Its a Logitech HD Webcam C270 which worked out of the box.
I have turned off the Playthrough software and also increased the buffer but it had no effect.
Audacity version is 2.1.2 from the Linuxmint / Ubuntu repositories

Did you reboot the computer?

If you are not using Skype, turn it off while recording.

If you are recording Skype with Audacity, don’t. Try


I have the same problem on linux, same webcam, same error, same version of Audacity, difference is that im using Arch Linux and VIA chipset. Sometimes it hangs after second or third click on recording button (not spaming the button but recording take) and sometimes right after first recording. Recording works fine on Windows but sometimes there is some delay, about 3 seconds long between the push of a recording button and actual recording start, especially after a fresh start, might be relevant.

See the same answer: In other words, do not record Skype with Audacity. Do not run Skype with Audacity.

Another one: do not use USB computer hubs.

Check on the ArchLinux forums if the webcam is class compliant and if not, whether it is supported with community drivers that they have made available.

It is simple to test whether Audacity is the problem. Record with another application.