Audacity hangs while recording and loses audio

I’m having an issue while podcast recording where Audacity hangs (not responding/freezes) and then fails to catch up. That is, sometimes it catches up and no audio is missed, but often nothing I say while it’s “not responding” is recorded. This results in my audio track being a few minutes shorter than my co-host who is recording on a separate device (mine was 50 minutes, his was 54 minutes).

Sometimes it’s for a second or two, other times it is several minutes of audio being lost. Not ideal!

I have previously upgraded to 16GB RAM, running Windows 10, and have Zoom + a Google Chrome tab open, besides Audacity. I feel like my laptop should be able to handle this, though it’s possible it’s a Chrome issue.

I’ve tried all the basic things like following Audacity guides to avoid dropouts, I’ve limited startup applications, I have plenty of storage on the hard drive where the temporary file is writing.

Any simple fix ideas, or do I need to look at upgrading my laptop to perhaps a SSD?

What happens if you work without Zoom (and any other communications software) running?
Does it improve in anything Audacity’s response?

You can get Zoom to record both sides of the conversation for you. There is a setting where they can deliver two independent tracks.

I think you are racing for control of the microphone. Zoom takes over the sound services in your machine to work right. It’s not optional. Sometimes, you can “share” your microphone with Zoom and both Far Side Send and a local recording are possible.

Sometimes not. Don’t bet the ranch on it.

You can cheat. Record your voice on a second recorder.

I did this sound test with my iPhone on a piece of plywood in my quiet garage.

If you’re both wearing headphones, earphones, or earbuds, the actual Zoom sound should be pretty good. See how it comes out with Zoom doing the heavy lifting.


Here’s a clip with the phone sitting on my desk.

Post back which way you decided to go.


I’ve used my phone as a backup before, it’s nowhere near the quality of a USB condenser microphone. I agree there are workarounds but this should be possible, no one else I podcast with has these issues.

I also encountered this issue where leaving my Audacity recording for a test (without Zoom) resulted in the recording being eight seconds behind the live recording timer. See in this attached image, the waveform as I was recording is well behind the red line indicating the timer:
image (2).png

it’s nowhere near the quality of a USB condenser microphone.

Maybe not, but run in pressure zone like that, mine compares favorably with some of my other microphones and recorders. Plus, in this instance, you would have a working podcast. Missing 4 minutes of a performance can’t be fixed.

Have you tried the Zoom solution?

Audacity will stop recording like that when it fails to get a working bitstream, but it’s not so bad that it loses its recording device. If you get lucky, it starts filling up the cache and then quick as a bunny, reads it all into the show.

Do you get any error messages?

do I need to look at upgrading my laptop to perhaps a SSD?

I haven’t bought a machine with a spinning metal drive since before 2009. I’m the last person to talk you out of that.

One of the people at work and I had almost the identical laptop except he had spinning metal and I had the SSD. We were working on a project and I had to change a setting on his machine. It was like slowly plowing through hip-deep snow. I asked him if there was something wrong. “No,” he said. “It’s always like that.”

upgrading my laptop to … a SSD?

Were you going to do it?

The further you get from a standard machine, the further you are from easy help, troubleshooting, or diagnostics.

co-host who is recording on a separate device

What does that mean? Use more words.

Recording Skype, Zoom, or other services fails a lot. That’s why they offer server recording.