Audacity hangs when Record icon is engaged

These are the circumstances:
Shuttle PC ~ ten years old
160GB harddisk
Windows XP SP3
Echo AudioFire2 sound device connected to computer via firewire
Echo AudioFire2 drivers ver5.5 from Echo website

When the drivers are loaded and the sound device connected, the AudioFire Console operates and shows input to the device apparently correctly. In addition the device headphone jack works, sending the signal to the headphone.

Audacity can be already started, or can be started at this point. Audacity options are set to Windows DirectSound, Primary Sound Driver, Primary Sound Capture and 2 (Stereo) Channels. Both Audacity and Echo sample rate are set to 44100.

When the Record icon is pressed, a project window opens with a line pulsing at zero with no linear movement. At the same time the Echo console freezes and wont respond again until Audacity is stopped and the sound device restarted by removing and replacing the firewire connector.

Other peripheral information: The sound device and Audacity work perfectly on another computer running Windows 7, with, what look to me, like an identical configuration. I’ve tried various Echo drivers, both earlier and later than the 5.5 version. I’ve tried an earlier (1.3.x) Audacity version with the same results.

With some direction, I can provie more information. Please help!



More information:

Lots of things can cause the Echo Console to hang: Starting a browser session, browsing (when the session starts OK). When the Console hangs, the headhone jack still transmits sound.

So there are two, I’m sure related, problems. Audacity Record fails, and the Echo Console fails.




Before you actually start recording, try going into monitoring and see if the sound is actually getting to Audacity.

Pull the meters really wide if you haven’t already. Click the right-hand meter edge and pull sideways.

Right-click inside the red recording meters > Start Monitoring. Play something. Do you get a bouncing meter? If you don’t, then Audacity is not being presented with the sound stream. If you do, then Audacity may be having trouble putting its temporary data somewhere or trouble with cache management.

The first thing the elves are going to do is insist you use Audacity 2.0.3.


Dueling messages.

If you go into Windows Control Panels, can you see your FireWire device? Is it selected?


Clicking the right hand meter causes the console to hang. Before doing this, there is no meter activity in Audacity.

Windows sees AudioFire record, playback and MIDI, and they are selected in Audacity.

If you make AudioFire default recording device in Windows ( ) does Windows Sound Recorder (sndrec32.exe) record from it?

Have you tried increasing “Audio to Buffer” in the Audacity Recording Preferences?


Sound Recorder causes exactly the same problem as Audacity. I am beginning to think that there is something catastrophically wrong with the computer itself. Or some basic parameter is set wrong. This appears in the log:

Hanging application audacity.exe, version, hang module hungapp, version, hang address 0x00000000.

For more information, see Help and Support Center at

This also:
wuauclt (860) The database page read from the file “C:WINDOWSSoftwareDistributionDataStoreDataStore.edb” at offset 11563008 (0x0000000000b07000) for 4096 (0x00001000) bytes failed verification due to a page checksum mismatch. The expected checksum was 2737987588 (0xa3326004) and the actual checksum was 2742181892 (0xa3726004). The read operation will fail with error -1018 (0xfffffc06). If this condition persists then please restore the database from a previous backup.

For more information, see Help and Support Center at

And this:
Faulting application spoolsv.exe, version 5.1.2600.6024, faulting module ole32.dll, version 5.1.2600.6168, fault address 0x0003f931.

For more information, see Help and Support Center at

Please attach Windows’ APPCOMPAT.TXT here - it should be listed in the error message. Here is how to attach files .

Did you increase the “Audio to buffer” setting in the Audacity Recording Preferences as I suggested?

The wuauclt is part of Windows Update.

Has AudioFire ever worked on this machine? If so, can you do a System Restore?

Have you tried any of the “archived” 4.x drivers: ?


I would also recommend adding more RAM. 1GB really isn’t enough even for Windows Xp S3. If you could find another stick of ram (Probably DDR1) for a few bucks it’d really help. If it’s DDR2 RAM, can buy a 2GB stick for $29 online.