Audacity freezing/crashing

So, I’ve been using Audacity to edit my podcast, and it was running fine. Then my computer asploded, and after rebuilding it, reinstalling windows, and installing Audacity, now I’m getting problems.

The first problem I encountered was in trying to run Noise Removal on one of the 3 raw recording tracks. I got the noise profile, started the noise removal process, and after about 3 seconds, I get an error saying “unhandled exception”. It’s an Audacity error box, not a Windows error box, BTW, but I don’t have the exact text handy. I’ll try to reproduce it and edit this post with the exact text sometime this week, but I don’t think there was an error code in the dialog box, just a vague description and “abort”, “retry”, and “ignore” buttons.

I managed to work around that by doing noise removal in chunks that would each take no more than about 2 seconds to process (length determined by trial-and-error), got that exported as a new file (to be run through CN Levelator), removed it from the project, and tried to import the next raw recording.

Here’s where the second problem cropped up. It starts to import the file, but freezes about 1/5 of the way through. No errors, no hard crash, the progress bar just stops progressing, and clicking the “abort” or “cancel” buttons just makes them go grayed-out. I have to pull up Task Manager and kill the Audacity process.

System info:
Windows 7 64-bit
3.6GHz quad-core AMD Phenom II 975 Black Edition
16GB DDR3 RAM @ 1600MHz
Audacity is installed on and storing temp files on a 128GB Crucial SSD.

Is it Audacity 2.0.0 or 2.0.1?

There should not be a problem with an SSD if it is working correctly.

Please click Edit > Preferences: Directories. If you have checked “Audio Cache”, uncheck it and click OK.


I was using 2.0.1 when I made that post. Since then, I have uninstalled it (using Revo Uninstaller Pro), and tried installing 2.0.0 and using that (which is what I was using before my comp asploded).

2.0.0 made it farther through the file-import process, but still hung. Haven’t tried the noise removal with it yet.

Unchecking the “use RAM” box under Audio Cache seems to have solved the import problem (which makes no sense when I have 16GB of ram and I’m only importing a 1.25GB file, but hey, whatever works).

The Audio Cache feature was designed to help users with old, slow hardware. It doesn’t sound like that applies to your machine. Leave the Audio Cache disabled, it often does not work properly with modern fast machines and I believe it will be disabled in the next release of Audacity for this reason.