Audacity freezes when changing the spectrogram scale from the dropdown menu of the spectrogram settings (SOLVED)

audacity version: 3.1.3
(audacity downloaded from website)
operating system: windows 11 (version 22h2, os build 25179.1000)
what i’m trying to do: change the spectrogram scale to logarithmic instead of linear from the spectrogram settings menu or from the preferences menu
what is preventing me from doing what i was going to do: the moment i try to click on any of the options from the dropdown menu to change the spectrogram scale (any scale) other than the one that has already been selected from my preferences (linear) audacity immediately freezes, but doesn’t crash
how to reproduce freeze: change the spectrogram scale in the dropdown menu to any other scale than the one already selected as a preference (changing it from the spectrogram settings in a track or from the preferences menu should both freeze audacity)
additional information: the bug has only occurred since i downloaded the current version of windows 11 (as i specified earlier, version 22h2, os build 25179.1000)

I cannot replicate this on W11 with 3.1.3 or the latest alpha test build I have for the upcoming 3.2.0


Good day,

I have a similar issue, but it’s freezing with all dropdown menus.
Windows Ver. 25179.rs_pre_release.220805-1349 - with Audacity 3.1.3 or alpha 3.2.0. ( deleted all / reinstall / remove registery values / clean folders / compatibility mode / run as administrator … )
I can’t find the source of issue but found an alternative solution, simply use keyboard instead of mouse to change values :
while in menus use the TAB key from your keyboard to change the selection and then change the values with arrows up or down.

Hope this helps,

Is that also a pre-release version of Windows?

i also noticed that it has been occurring on other dropdown menus, but this seemed to fix the problem

As per Today, there was a new windows update, everything is now working fine for me.

Windows release build 25182.rs_prerelease.202208-12-1437
Hope it’s ok for you too.

Glad to hear you have this issue corrected. :smiley: