Audacity freezes "Not Responding" with every edit[SOLVED]

Running Audacity 2.0.4 on Windows 7. This happens every time when editing, especially edits like deleting small 0-5s segments on single track projects or inserting <1s silences. It freezes for about 5 seconds, goes Not Responding and often minimises the windows with every single edit. Needless to say, this is infuriating.

I’m working with short tracks, all less than 10 mins and have tried working as a wav as well as aup. I’m running a i3 2120 with 8GB RAM so the system should be able to cope with basic audio editing fine.

Any ideas?

I don’t understand “minimises the windows”, but if you are selecting using the keyboard or Selection Toolbar this may be very slow. That will be fixed in the next 2.0.6 version when released.

Where is your temporary directory (Edit > Preferences, choose Directories on the left) and where are you saving Projects to. If it’s a slow network drive that could be an explanation. For recordings at least you want to use a local drive.


When Windows 7 goes Not Responding, quite often the window focus changes and things get minimised. It happens quite often with 100% CPU video encoding. In this case it minimised the Audacity window with every edit.

Turns out the issue was saving to a network drive even though I’m on a GbE connection. Any format I can work in that will mitigate this because I can easily transfer at 80MB/s and it’s only ever files that are about 1-10 minutes long usually…