Audacity fails to open files through symbolic link

When I try to open a file that’s actually a link, created with ln, Audacity fails to recognise it. Other application are fine.
A co-worker even has no problems with this in Audacity.
I’m on Ubuntu 18.04 and Audacity 2.3.2

Seems to work fine for me.

If you’re talking about opening an Audacity Project, you must have a copy of the project’s _data folder, or a link to the project _data folder, in the same location as the link to the .aup file. The name of the _data folder, or link to the _data folder, must have the same name as the original _data folder.

I don’t think Audacity supports samba share network drives.

I’m on Xubuntu 18.04.

Thanks for your reply. I am trying to open (or import for that matter) a simple .wav file. The file sits on our NAS and I access it through a link. Nothing special. Strange that it works for my colleague and for you, but not for me.

That’ll be the problem.

Look in “Edit menu > Preferences > Import / Export” (Import / Export Preferences - Audacity Manual)
Ensure that “Copy uncompressed files into the project (safer)” is selected.

When attempting to import the file, if you are prompted to “Make a copy” or “Read the file directly”, select “Make a copy” (Importing Audio - Audacity Manual)

If that doesn’t work, then the simplest solution is to manually copy the file to your local computer, and import from there.


“Copy uncompressed files into the project (safer)” was already selected, so the question on import is asked anymore.

I am making copies of the files myself, but that gets annoying fast.

If they are also using Ubuntu, perhaps take a look to see how their system mounts the NAS drive, and set yours up the same way.

While I’m not using symlinks to my NAS files, the NAS is mounted on my Fedora Linux box via NFS, not Samba.