Audacity failed to read from a file from C:

Hi All,

I’m getting the “Audacity failed to read from a file in C:” error.

I’m using Audacity 2.2.1 ( on Windows 10 Pro 64bit.

I have the file, and the data file in the same location. I can open up and play the project, I can cut, trim, and move things around - the whole project plays just fine. However if I try to apply effects, or export (to any format it would seem) I get this error message. I can also save and re-open the podcast.

I suspect I’ve created this problem by saving the files on a OneDrive share, and that some of the data files have been lost/corrupted in transit. However given that I can play the file, I’m hoping there’s a way I can export it (it’s a podcast, and I’d hate to loose it).

Can anyone help? I’ve uploaded a zip of the project file and the associated data files to!AnPcO8-vW7o4q3nH9rF62rJnn_rH.


I am in the exact same boat and anxiously await someone being able to help out

Hi All,

In an effort to diagnose this (which appears to apply to this project only) I’ve opened up the project file and found to my delight that it is xml (yes, I’m new at this Audacity thing). I’ve opened it up on excel, and copied all the filename attributes into a file called files.txt. I then ran the following in an effort to find what I had assumed would be a missing file.

for /F "tokens=*" %A in (files.txt) do @dir %A /s > NUL; @if errorlevel 1 @echo Missing %A;

But alas, no missing files… I don’t know if that is because my command line scripting is so crap, or if there are truly no missing files.

Appreciate any help…


The problem is “file permissions”. The files are write protected, so Audacity is unable to modify the project. You need to fix the file permissions so that they are not write protected.

Did you also use OneDrive?

There’s also some bad data.
I think I can recover most of this project.

Thanks Steve - I was really excited to see this. However… after some initial excitement (yes the One Drive folders were protected, but the files were not), and several belts and braces checks (attrib -r /s; copying to a new directory, with new names etc), I’m still no closer to a solution.

Is it possible for me to turn logging up so I can see what’s going on? Here’s everything in my log:

23:46:50: Audacity 2.2.1
23:46:50: Trying to load FFmpeg libraries...
23:46:50: Trying to load FFmpeg libraries from default path, 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
23:46:50: Looking up PATH environment variable...
23:46:50: PATH = 'C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Skype\Phone\;C:\Users\dim\AppData\Local\Microsoft\WindowsApps;'
23:46:50: Checking that 'C:\Program Files (x86)\FFmpeg for Audacity' is in PATH...
23:46:50: Warning: FFmpeg directory 'C:\Program Files (x86)\FFmpeg for Audacity' is not in PATH.
23:46:50: Temporarily prepending ';C:\Program Files (x86)\FFmpeg for Audacity' to PATH...
23:46:50: Checking for monolithic avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
23:46:50: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
23:46:50: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: the specified procedure could not be found.)
23:46:50: avformat not monolithic
23:46:50: Loading avutil from 'avutil-52.dll'.
23:46:50: Loading avcodec from 'avcodec-55.dll'.
23:46:50: Loading avformat from 'C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll'.
23:46:50: Returning PATH to previous setting...
23:46:50: Actual avutil path C:\Program Files (x86)\FFmpeg for Audacity\avutil-52.dll
23:46:50: Actual avcodec path C:\Program Files (x86)\FFmpeg for Audacity\avcodec-55.dll
23:46:50: Actual avformat path C:\Program Files (x86)\FFmpeg for Audacity\avformat-55.dll
23:46:50: Importing symbols...
23:46:50: All symbols loaded successfully. Initializing the library.
23:46:50: Retrieving FFmpeg library version numbers:
23:46:50:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
23:46:50:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
23:46:50:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
23:46:50: FFmpeg libraries loaded successfully.


That would make my day! I’m also happy to do this myself - I just need a point in the right direction… I don’t know how to identify the bad data (I presume removing it is a matter of hacking the project file, and possibly also deleting the audio segment.

I’ve posted a copy here. There’s a few bits missing due to bad data, but most of the project is there.
The download page has a lot of adverts, and may ask you to “sign up”, but there is no need to register for anything to download this file:

Woo hoo! You rock, thank-you.

I’d love to know where I should learn how to do this myself, but am super happy that you’ve done that for me. Thanks!

How I fixed it:

I’m on Linux, which makes the file permissions easily visible, so the main problem stood out like a sore thumb.
I used the “chmod” to fix the file permissions (I don’t know what the equivalent is for Windows - Windows has always been bad at handling file permissions).

After fixing the file permissions, I found that I could apply effects (tested with “Amplify -10 dB”) to parts of the project, but not all of the project.
Looking closely at the tracks, I saw some parts that appeared as “flat line” (silence).

I’m using a debug build of Audacity, which gives additional warnings.

When zooming in on these flat line areas, a debug error occurred, which confirmed my suspicion about bad data. So I selected the flat line region, and applied “Split Delete” ( to remove the bad data but retain empty space where the data was.

There were 3 or 4 regions with bad data. After removing them, effects could be applied to the entire project, indicating that the remaining data appeared to be OK.
Saved the project → Zipped it, → uploaded → downloaded and checked → post reply to forum.

Only by compiling the code to make a “debug” build.
Debug builds are not generally recommended for production use as they can fire off debug messages that are not errors - just an annoyance unless you are developing the code.

I’d like to know if eh_sully was also using OneDrive.

I have found a relatively workaround! I cannot follow all the code and syntac fixes that were offered.

But I spent 3 hours working on an editing project and then I went to save it and got that “Audacity failed to read a file in C:” error message.

I tried downloading around 6 different older versions of Audacity, but to no avail. Then, I could not load up my project file anymore…that was annoying. Then I change the extension from “.aup” to “.aup3” and I was able to load the project, BUT not save it, because of the “Audacity failed to read a file in C:” error message.

So, the work around was to open a new blank Audacity file and copy and paste sections of the project. What I discovered was there was a small section in the audio track recording (only 10 seconds), which I could not copy and paste, due to the “Audacity failed to read a file in C:” error message. So, I was able to copy and paste my entire project (minus 10 second), into a new audio file and then save it via MP3 route…problem solved.

Of course, I took the original recording to grab the missing 10 seconds I needed.

I hope this helps. I use a Windows personal PC by the way.

Note that the post you are replying to is four (4) years old. And I am glad that you found a solution to your issue. :smiley: I have a little experience with recovering broken projects myself and I have used the copy-paste technique myself in the past to bypass a glitch in an open project file.

And I’m glad you got updated to Audacity 3.x.x. :smiley: