Audacity fail on Mac

I can’t find a way to record by USB to Audacity. I am using a Mac OS 12, I have a USB converter going from USB C out of Mac with a USB A cable plugged into it coming from a USB mixer. No matter what I try I can only get and recording from the in built mic of the Mac, I would like to record by USB. Any help please? I feel like I have tried everything yet I can’t solve the issue :astonished:


Please see:


Still doesn’t work for me, can’t see on my Mac what is described

With the mixer connected and powered on, click on Apple (menu) > System Preferences, then the Sound panel, then the Input tab.

You should see your USB device listed there. If you don’t, then the Mac doesn’t see the device and neither will Audacity. If you can see it, click it to select it, close System Preferences then start Audacity. Audacity should now see the USB mixer.

What version of Audacity are you using?

– Bill

I can see the mixer following what you have said, but after clicking on it nothing happens. I press record and nothing is picked up. It seems to switch back to built in mic? Driving me nuts! I’m using 3.2.1. Thanks

The levels show they are picking up at the bottom of this menu, but there’s nothing on the recordings…

What menu?

If you are using Audacity 3.2.1, use the Audio Setup Toolbar to select your USB device (probably “USB Audio CODEC”) as your input device.

If you don’t have the Audio Device Toolbar in your version of Audacity, see the bottom of that linked page for other ways to access the device settings.

– Bill

I have done this over and over, still nothing. Think I may just give up :man_facepalming:

Have you tried Transport > Rescan Audio Devices ?
– Bill