audacity.exe missing icon in program files directory?!

Hi all,

I have been using the Audacity app for quite a while now and have noticed a rather strange… glitch or bug with the app’s icon.
At this point I’m somewhat sure that Windows is not displaying the icon correctly in all places, but not too sure why.
The icon for some bizarre reason will not show correctly if installed in the Program Files directory in Windows (C:) drive yet the zip installable one shows its icon just fine. Both the Installer version and Zip Install version are the same v2.3.2 running on Windows 10 v10.0.18362.

I have searched on the web for a solution but none of them have worked.
I’ve tried uninstalling and reinstalling the app, didn’t work, and rebuilding the explorer.exe cache, which does not appear to be the issue since the zip installed app works just fine showing the icon and everything.

Screenshot showing what I described: https://imgur.com/a/DixvZWp

Hoping someone can help me fix this as I am unsure why this is happening or what could be causing it.

You may need to rebuild the Windows “icon cache”. There’s a “how to” here: https://www.howtogeek.com/232779/how-to-rebuild-a-broken-icon-cache-in-windows-10/

Could also be a permissions issue. Making manual entries in the program files area can prevent access, even if the user has admin rights. Try simplifying the permissions on the audacity folder by stopping inheritance then removing all but the basic ones then cascading those down the audacity sub-folders. ( With full access for yourself and system and administrators of course ).