Audacity doesn't open in moutain lion

Hi! The Audacity 2.0.3 will not open on my mac. I’ve tried several tips given in other threads. Now opened but appeared an error …

XPM: Malformed Pixel Data.

In other attempts he never opens.

Does anyone know how to solve?


Are you opening Audacity directly, or by double-clicking an Audacity project file (.aup file)?

Audacity 2.0.3 works fine on my Mountain Lion iMac.

I’ve never seen that type of error message before.

– Bill

On my Mountain Lion (OSX 10.8.2) Audacity won’t open and gives the following message:

“Audacity” can’t be opened because it is from an unidentified developer.

Your security preferences allow installation of only apps from the Mac App Store and
identified developers.

I tried downloading it from both the .dmg option and the .zip option. Neither worked.

I was actually able to open and use it using Terminal and by changing directory to where the raw unix app resides.
However, this is quite inconvenient and inelegant.

Maybe I can change my security privileges? I looked under Apple → System Preferences → Security & Privacy
but I don’t see anything that would address this problem.

If anyone has a clue how to fix this, please let us know!

See here My Mac laptop says no to Audacity 2.2 - #5 by Gale_Andrews .

This information is also in the “Install.txt” file in the DMG.


Try this to solve your problem
Open Settings.
Go to Security and Privacy.
Unlock padlock on bottom of window.
Click in circle “Anywhere”.
Close Settings

Or as Gale previously wrote:
“if you prefer the extra safety of Mac informing you that apps are not from “an identified developer”, leave the preference as it is. Right-click or control-click on the Audacity application in Finder, choose “Open”, then in the dialogue box that appears, choose “Open”. You will then be able to launch Audacity normally on subsequent occasions.”

Re-setting the security to allow from “anywhere” solved the problem. Thanks.