Audacity doesn't open certain project

I’m using Audacity 2.3.0 and was working on a fairly large .aup file. Decided to take a break and when I went to open it again, an Error Importing message showed up. The message reads exactly:

“LOCATION OF FILE” is an Audacity Project file. Use the ‘File > Open’ command to open Audacity Projects.

I opened the file exactly how it said to open it, and yet it still interprets it as me trying to import an .aup file. This only happens on this specific file. I tried every other .aup file in that folder and they all worked perfectly. I checked the data folder for it and all the samples of audio are there in mono form. Is there any easy way to recover this file?

me trying to import an .aup file.

Close Audacity and open the .aup file in a text editor. Just to look. Don’t save anything. It should look something like this. This one has been cleaned up a little for the picture, but these are the parts. Note the show name is burned into the programming.

Does the show name match what you think the show name is? Is the file full of characters other than those or weird graphic characters?

Or no characters.