Audacity does not start when updating from Audacity 2.2.0 to 2.3.0

= Problem =
Audacity does not start when updating from Audacity 2.2.0 to 2.3.0

= Expectation =
Audacity 2.3.0 to start

= Procedure =

  1. I downloaded the 2.3.0 installer (not zip) from Audacity’s official page and installed it
  2. Double-click the generated launch icon
  3. Windows standard notification sound is generated
  4. But the Audacity window does not appear
  5. Audacity is not displayed on the task bar

= Supplement =
· When I see the task manager, the Audacity process starts up. However, it will automatically end after several seconds.
· I have three audio drivers. Only one was valid, and other invalidated. I tried all three patterns, but the problem is not solved.
· Roll back to 2.2.0 in the same environment, Audacity started up as expected

= Environment =
OS
· Windows 10 Home (version 1803, build 17134.285)
CPU
· Intel Core i7-4770
Video card
· NVIDIA GeForce GTX 770
Audio driver
· NVIDIA High Definition Audio
· Realtek Surround Audio Controller
· Razer Surround Audio Controller

If you need more information, please reply.
I appreciate your efforts.

Try reinstalling Audacity from the EXE installer (available here: https://www.audacityteam.org/download/windows/) and during the installation, look out for the option to “Reset Preferences”. Select that option when it appears.
On first run, confirm that you want to reset preferences.

This sounds a lot like problems I have had with Realtek drivers. Try temporarily disabling them in device manager to see if Audacity will start normally. If its successful report back and perhaps we can come up with a permanent solution.
The other similar issue related to default sample rates. Try setting your audacity preferred sample rate the same as the windows default sample rate for each recording device. If you can’t start audacity to do this you may have to edit the DefaultProjectSampleRate value in audacity.cfg manually. ( Its usually in %appdata%\audacity so type echo %appdata% to find that on your machine).