Audacity does not see JACK Audio Connection Kit

As stated in the title. I have checked, but it didn’t help;

I have already successfully setup MuseScore and Carlo with JACK, so it should not be a JACK problem.

I tried both 2.1.2 and 2.1.3 alpha versions, none of which has the option.

Also, I have noticed that audacity starts up slower (and is slow when rescanning audio devices) compared to before (happened about a month ago, before I installed JACK).

Any solutions to make audacity work with JACK?

Thanks in advance :slight_smile:

You posted in the Windows board and registered as on Windows 10.

If you are asking about Audacity support for JACK for Windows, that is only experimentally supported and you would have to compile Audacity to enable it.

If you are actually on Linux, please state exactly what version of Linux and where you obtained Audacity or if you built it yourself. Also see


Hi, indeed I am on windows 10. I tried to build audacity but failed miserably (I am terrible at this dependency thing :stuck_out_tongue: )

I then tested it on Ubuntu and sure enough it worked.

Will future compiled binary release of audacity on windows include JACK support though?

See the yellow box at the top of for some pointers.

What is it that you are trying to do? Do you need JACK, or just ASIO?

Probably not, due to there being little “demand”, unless we decide to provide ASIO support through JACK.

How to build Audacity with JACK support isn’t officially documented anywhere, and I don’t know if that support still builds. If anyone wants to try it, see


Ahh thanks for the tips, I will try to compile them again.

I think ASIO would suffice as JACK would be able to receive audio from that(?) My goal is just to route audacity audio through jack.

As far as I know, yes, providing you have an ASIO-capable sound device or use the ASIO4ALL wrapper.